Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000396Core InformUnderstandingpublic2010-11-06 19:492014-05-07 07:33
Reporterzarf 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6F95 
Target VersionFixed in Version6L02 
Summary0000396: "only understood you as far..." error produces wrong output for directions
Description>north xyzzy
I only understood you as far as wanting to north.

>pick me up xyzzy
I only understood you as far as wanting to pick yourself up.

>north xyzzy
I only understood you as far as wanting to north yourself up.


The first two errors are correct; the third is wrong. (And vaguely filthy-sounding.)

This only happens with directions. "jump xyzzy" always produces the correct error output.

(Experiment reveals that this bug has been in the library since I6 days.)
Minimal Source Text To Reproduce
The Kitchen is a room.
Test me with "north xyzzy / pick me up xyzzy / north xyzzy".
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0000798)
jmcgrew (administrator)
2010-11-06 21:21

Arguably, the first one is also wrong and should say "go north" instead.
(0002517)
graham (administrator)
2014-02-16 11:49

Fixed, and the parser is now able to reply:

I only understood you as far as wanting to (go) north.

where the verb has been inferred.

- Issue History
Date Modified Username Field Change
2010-11-06 19:49 zarf New Issue
2010-11-06 21:21 jmcgrew Note Added: 0000798
2010-11-06 21:21 jmcgrew Status new => confirmed
2010-11-06 21:21 jmcgrew Steps to Reproduce Updated View Revisions
2014-02-16 11:49 graham Note Added: 0002517
2014-02-16 11:49 graham Status confirmed => resolved
2014-02-16 11:49 graham Resolution open => fixed
2014-02-16 11:49 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker