Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000395Core InformIndexingpublic2010-11-06 18:412011-01-10 11:15
ReporterRon Newcomb 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
PlatformPPCOSMac OS XOS Version10.4
Product Version6F95 
Target VersionFixed in Version6G60 
Summary0000395: New "to be..." relation verbs missing from phrasebook, and not permitted passive voice
DescriptionNot sure if this is a bug or not. The attached (and admittedly silly) source does not have "to be parenting" listed in the phrasebook of the index (in the bottom-most "verbs used in descriptions" section).

Furthermore, "to be able to..." relations automatically support the passive voice, so "Bob can remember jailtime" is equivalent to "Jailtime can be remembered by Bob". This doesn't seem to be true for "to be..." relation verbs, per my testing. (By design? "To be able to.." verbs require the (he is remembered) parenthetical to construct the passive, which "to be.." will not accept, saying it already knows all about "to be".)

I was checking the index to see if the passive, "is parented by", was listed, and was surprised to find that it wasn't listed at all!

 
Minimal Source Text To Reproduce
There is a room.

Single-inheritance relates one thing (called the parent) to various things.
The verb to be parenting implies the single-inheritance relation.
When play begins, now yourself is parenting yourself.  [compiles but missing from index]
[When play begins, now yourself is parented by yourself.]  [does not compile]
TagsNo tags attached.
Effect(cosmetic) Index is created incorrectly
Attached Files

- Relationships

-  Notes
(0000795)
jmcgrew (administrator)
2010-11-06 19:19

Section 13.10 of the manual refers to the verbs created with this syntax as "prepositions". It wouldn't make sense to allow the passive voice for all such things ("the mug is parted of by the handle"?), so I suspect the lack of a passive voice is intentional, but the manual could stand to be more explicit.

Please open a separate report for that, though.
(0000805)
Ron Newcomb (reporter)
2010-11-08 19:51

Ah, that makes sense. Nevermind the passive voice thing then.

Er, am I looking in the wrong place for preposition relations? (I'm not in front of the IDE to go looking again, but I coulda swore that place would be the only place they'd appear.)
(0000806)
jmcgrew (administrator)
2010-11-08 19:53

No, I don't see it in the index either.
(0000834)
graham (administrator)
2010-11-19 15:44

Such usages are now indexed. They were missed out before simply because they didn't conjugate in any interesting way - they are simply prepositional forms, so the conjugation is always just that of "to be". (If you want "parenting" to conjugate, try creating "to parent" as a verb.) The idea is to use this to create things like "To be upon".

However, they should certainly have been in the lexicon index, and now they are.

- Issue History
Date Modified Username Field Change
2010-11-06 18:41 Ron Newcomb New Issue
2010-11-06 19:19 jmcgrew Note Added: 0000795
2010-11-06 19:19 jmcgrew Severity mild => cosmetic
2010-11-06 19:19 jmcgrew Status new => confirmed
2010-11-06 19:19 jmcgrew Steps to Reproduce Updated View Revisions
2010-11-08 09:21 jmcgrew Status confirmed => feedback
2010-11-08 19:51 Ron Newcomb Note Added: 0000805
2010-11-08 19:51 Ron Newcomb Status feedback => new
2010-11-08 19:53 jmcgrew Note Added: 0000806
2010-11-08 19:53 jmcgrew Status new => confirmed
2010-11-19 15:44 graham Note Added: 0000834
2010-11-19 15:44 graham Status confirmed => resolved
2010-11-19 15:44 graham Resolution open => fixed
2010-11-19 15:44 graham Assigned To => graham
2010-12-23 17:37 jmcgrew Fixed in Version => 6G60
2011-01-10 11:15 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker