Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000390Core InformPropertiespublic2010-11-05 20:452011-01-10 11:15
Reporterjmcgrew 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6F95 
Target VersionFixed in Version6G60 
Summary0000390: Misleading error when giving properties to an action name (and some other types)
DescriptionThe code below gives this error:

Problem. You wrote 'An action name has a number called difficulty' : but this is a kind of value which is not allowed to have properties of its own, because this would be impossible to store in any sensible way. For instance, 'A scene has a number called difficulty.' is fine because there are not many scenes and I know them all, but 'A number has a text called French translation.' is not allowed, because storing something for every possible number takes an impossible amount of space. (See the Kinds index for which kinds can have properties.)

The Kinds index does say these types can't have properties, but "impossible to store in any sensible way" isn't quite true. Built-in enumerated types like action name and use option don't have substantially different storage requirements from user-defined kinds of value.
Minimal Source Text To Reproduce
Dojo is a room. An action name has a number called difficulty.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
(0000863)
graham (administrator)
2010-11-21 15:52

Very well. A different excuse is now given, but the answer is still "no".

- Issue History
Date Modified Username Field Change
2010-11-05 20:45 jmcgrew New Issue
2010-11-05 20:45 jmcgrew Issue Monitored: jmcgrew
2010-11-05 20:45 jmcgrew Issue End Monitor: jmcgrew
2010-11-05 20:45 jmcgrew Status new => acknowledged
2010-11-05 20:49 jmcgrew Severity mild => cosmetic
2010-11-06 10:41 EmacsUser Status acknowledged => confirmed
2010-11-21 15:52 graham Note Added: 0000863
2010-11-21 15:52 graham Status confirmed => resolved
2010-11-21 15:52 graham Resolution open => fixed
2010-11-21 15:52 graham Assigned To => graham
2010-12-23 17:37 jmcgrew Fixed in Version => 6G60
2011-01-10 11:15 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker