Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000381Core InformSource text and punctuationpublic2010-11-01 17:592011-01-10 11:15
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.4
Product Version6F95 
Target VersionFixed in Version6G60 
Summary0000381: Confusing error in response to a particular kind of missing semicolon
DescriptionThis one might be a won't-fix. Inform seems to read

- - - -
        say "Blue?"
    otherwise:
- - - -

as a single statement, and also indented to match the ``otherwise'' part. In consequence, the attached source yields

- - - -
Problem. The phrase or rule definition 'This is the red rule' is written using the 'colon and indentation' syntax for its 'if's, 'repeat's and 'while's, where blocks of phrases grouped together are indented one tab step inward from the 'if ...:' or similar phrase to which they belong. But the phrase 'if the player is nothing' , which ought to begin a block, is immediately followed by <no text> at the same or a lower indentation, so the block seems to be empty - this must mean there has been a mistake in indenting the phrases.
- - - -

rather than

- - - -
Problem. You wrote 'say "Blue?" otherwise begin' : but this is a phrase which I don't recognise, possibly because it is one you meant to define but never got round to, or because the wording is wrong (see the Phrasebook section of the Index to check). Alternatively, it may be that the text immediately previous to this was a definition whose ending, normally a full stop, is missing?
- - - -

or

- - - -
Problem. You wrote 'otherwise' : but the punctuation here ':' makes me think this should be a definition of a phrase and it doesn't begin as it should, with either 'To' (e.g. 'To flood the riverplain:'), 'Definition:', a name for a rule (e.g. 'This is the devilishly cunning rule:'), 'At' plus a time (e.g. 'At 11:12 PM:' or 'At the time when the clock chimes') or the name of a rulebook, possibly followed by some description of the action or value to apply to (e.g. 'Instead of taking something:' or 'Every turn:').
- - - -

either of which would be more indicative of the real problem.
Minimal Source Text To Reproduce
There is a room.
This is the red rule:
	if the player is nothing:
		say "Blue?"
	otherwise:
		say "Red!"
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
(0000857)
EmacsUser (manager)
2010-11-21 13:09

Oops. Fixed the indentation in the description.
(0000867)
graham (administrator)
2010-11-23 23:29

I've marginally improved matters.

- Issue History
Date Modified Username Field Change
2010-11-01 17:59 EmacsUser New Issue
2010-11-01 22:26 jmcgrew Status new => acknowledged
2010-11-02 21:52 jmcgrew Status acknowledged => confirmed
2010-11-21 13:09 EmacsUser Note Added: 0000857
2010-11-21 13:09 EmacsUser Description Updated View Revisions
2010-11-23 23:29 graham Note Added: 0000867
2010-11-23 23:29 graham Status confirmed => resolved
2010-11-23 23:29 graham Resolution open => fixed
2010-11-23 23:29 graham Assigned To => graham
2010-12-23 17:37 jmcgrew Fixed in Version => 6G60
2011-01-10 11:15 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker