Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000038Core InformModel worldpublic2010-06-15 13:002010-07-04 16:27
ReporterJim Aikin 
Assigned Toemshort 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version6E72 
Summary0000038: Bad output from examining enterable supporter
Description>x chair
The comfy chair is green.

On the comfy green chair .
Minimal Source Text To Reproduce
The Lounge is a room. "Ah, the Lounge! How relaxing."

The comfy green chair is an enterable scenery supporter in the Lounge. The description is "The comfy 
chair is green."

The player is on the chair.

Test me with "x chair".
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships
related to 0000303closedgraham Incomplete line is printed when examing a supporter with only undescribed objects 

-  Notes
emshort (administrator)
2010-06-15 15:47

My fault, I think. It's an easy fix; I'll send a patch this evening.
emshort (administrator)
2010-06-15 19:59

A patch has been submitted.

This bug exposed an equivalent bug if the player examined a container that contained him, and this one was slightly subtler, because we did not want the message to say "In the kiosk .", obviously -- but we also don't want the message to fall through to "The kiosk is empty." when it plainly contains the player.

- Issue History
Date Modified Username Field Change
2010-06-15 13:00 jmcgrew New Issue
2010-06-15 13:01 jmcgrew Status new => acknowledged
2010-06-15 15:47 emshort Note Added: 0000008
2010-06-15 15:47 emshort Assigned To => emshort
2010-06-15 19:27 emshort Reproducibility have not tried => always
2010-06-15 19:59 emshort Note Added: 0000010
2010-06-15 20:34 jmcgrew Status acknowledged => resolved
2010-06-15 20:34 jmcgrew Resolution open => fixed
2010-06-30 18:08 jmcgrew Fixed in Version => 6E72
2010-07-01 23:07 jmcgrew Status resolved => closed
2010-07-04 16:27 jmcgrew Reporter jmcgrew => Jim Aikin
2010-09-25 01:26 jmcgrew Relationship added related to 0000303

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker