Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000377Core InformExtensionspublic2010-10-30 19:562014-05-07 07:35
Reporterektemple 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6F95 
Target VersionFixed in Version6L02 
Summary0000377: Extension documentation prettifier drops final -) of multiline I6 inclusions in example code
DescriptionMultiline inclusions in extension examples do not paste correctly from the documentation. The closing -) is not pasted.
Minimal Source Text To Reproduce
Testing by Bug Reporter begins here.

When play begins:
     do nothing.

Testing ends here.


---- DOCUMENTATION ----

This is a line of dummy text.

Example: * Not much to this one!
	
	*: "Test Example"
	
	Include Testing by Bug Reporter.
	
	Test is a room.
	
	Include (-
	
		Property KI_0;
	
	-).
	
	When play begins:
		say "Hello!"
Tagswrongeffect
Effect(cosmetic) Index is created incorrectly
Attached Files

- Relationships
related to 0000205closedgraham The paste icon in extension's examples don't paste the (- I6 inclusion operator correctly. 

-  Notes
(0000767)
EmacsUser (manager)
2010-11-01 17:19

This looks an awful lot like 0000205, and the test case in 0000205 still fails for me. Perhaps this is a reopen?
(0000768)
jmcgrew (administrator)
2010-11-01 22:42

The test case in 0000205 works for me on Windows.

This one fails, though. The closing -) isn't just missing from the pasted code: it's completely missing from the documentation page.
(0001388)
graham (administrator)
2011-10-16 05:37

Fixed both issues here (the absence of the end-marker in the paste, and in the documentation).

- Issue History
Date Modified Username Field Change
2010-10-30 19:56 ektemple New Issue
2010-10-30 21:38 jmcgrew Effect (serious) Compiler rejects valid code => (cosmetic) Index is created incorrectly
2010-10-30 21:38 jmcgrew Severity mild => cosmetic
2010-10-30 21:38 jmcgrew Status new => acknowledged
2010-11-01 17:17 EmacsUser Relationship added related to 0000205
2010-11-01 17:19 EmacsUser Note Added: 0000767
2010-11-01 17:19 EmacsUser Status acknowledged => confirmed
2010-11-01 22:29 jmcgrew Tag Attached: wrongeffect
2010-11-01 22:42 jmcgrew Note Added: 0000768
2011-10-16 05:37 graham Note Added: 0001388
2011-10-16 05:37 graham Status confirmed => resolved
2011-10-16 05:37 graham Resolution open => fixed
2011-10-16 05:37 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:35 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker