Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000374Core InformPropertiespublic2010-10-30 06:022014-05-07 07:35
Reporterektemple 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6F95 
Target VersionFixed in Version6L02 
Summary0000374: Condition properties cannot be shared between kinds
DescriptionAttempting to assign condition properties of three or more terms to multiple kinds results in the message:

"You wrote 'An arthropod is usually calm' : but the property insect condition for the arthropod is not allowed to exist, because you haven't said it is. What properties something can have depends on what kind of thing it is: see the Index for details."

Inform correctly dealt with this situation in previous builds (and still does it properly with either/or properties, which use a different storage mechanism, I would guess), but now insists on relating the property only with the first kind.
Minimal Source Text To Reproduce
Test is a room.

An insect is a kind of thing. An insect can be aggressive, skittish, or calm. An insect is usually calm.


An arthropod is a kind of thing. An arthropod can be aggressive, skittish, or calm. An arthropod is usually 
calm.
Additional InformationThe workaround is either to give each declaration of the property the same, specific name:

An insect is a kind of thing. An insect can be aggressive, skittish, or calm (this is its touchiness property). An insect is usually calm.
An arthropod is a kind of thing. An arthropod can be aggressive, skittish, or calm (this is its touchiness property). An arthropod is usually calm.

...or to have every subsequent declaration after the first refer back to the first declaration:

An insect is a kind of thing. An insect can be aggressive, skittish, or calm. An insect is usually calm.
An arthropod is a kind of thing. An arthropod can be aggressive, skittish, or calm (this is its insect condition). An arthropod is usually calm.

The latter is source-order dependent and thus pretty fragile.
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships
related to 0000576closedgraham Properties and adjectives with overlapping names on different kinds interfere with one another 

-  Notes
(0001501)
graham (administrator)
2011-12-19 15:24

This was a delicate one. It's not exactly a bug fix, more of a gap in the existing semantics, but of course the fact that there was a gap is a sort of bug all by itself. What I've done is to make Inform check existing properties, so that it's unnecessary to declare a common name, since Inform can deduce this.

There is consequently a new problem message to handle a case where the user writes:

An arthropod is a kind of thing. An arthropod can be aggressive, skittish, jabby, or calm. An arthropod is usually calm.

where "jabby" wasn't one of the options earlier on.

- Issue History
Date Modified Username Field Change
2010-10-30 06:02 ektemple New Issue
2010-10-30 21:36 jmcgrew Priority high => normal
2010-10-30 21:36 jmcgrew Status new => acknowledged
2010-10-31 15:08 jmcgrew Status acknowledged => confirmed
2011-12-19 15:24 graham Note Added: 0001501
2011-12-19 15:24 graham Status confirmed => resolved
2011-12-19 15:24 graham Resolution open => fixed
2011-12-19 15:24 graham Assigned To => graham
2012-03-12 17:43 EmacsUser Relationship added related to 0000576
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:35 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker