Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000348Core InformActionspublic2010-10-23 01:472010-10-29 09:02
Reporteralex 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000348: WI does not mention that the thing in actions ``applying to one topic and one thing'' is the second noun, not the first
DescriptionThe code below produces I6 runtime errors:

>type "qwertyuiop" on laptop
You can't type on
[** Programming error: tried to test "has" or "hasnt" of <illegal object number 203> **]

[** Programming error: tried to test "has" or "hasnt" of <illegal object number 203> **]

[** Programming error: tried to test "has" or "hasnt" of <illegal object number 203> **]

[** Programming error: tried to test "has" or "hasnt" of <illegal object number 203> **]

[** Programming error: tried to test "has" or "hasnt" of <illegal object number 203> **]

[** Programming error: tried to test "has" or "hasnt" of <illegal object number 203> **]
a <illegal object number 203>.
Minimal Source Text To Reproduce
Place is a room.

The player carries a laptop.

Typing it on is an action applying to one topic and one thing. Understand "Type [text] on/onto/in/into 
[something]" as typing it on.

Report typing on:
	say "You can't type on [a noun].";
	rule fails.

A program is a kind of thing.

The laptop has an object called the selected window.

Instead of typing on the laptop, try typing the topic understood on the selected window of the laptop.


Before typing on a program, now the second noun is the selected window of the laptop.

Understand "type [text]" as typing it on.

Rule for supplying a missing second noun when typing on:
	if the laptop is visible:
		now the second noun is the laptop;
	else:
		say "What? You're talking complete nonsense."

An error message is a program. The error message is part of the laptop. The selected window of the laptop 
is the error message.
Additional Information"No idea what's causing this. However, this mysteriously seems to work fine:"

<code>
Place is a room.

Typing it on is an action applying to one topic and one thing. Understand "Type [text] on/onto/in/into [something]" as typing it on.

Report typing on:
say "You can't type on [a noun].";
rule fails.

The player carries a PDA.

Instead of typing on the PDA, say "You type [the topic understood]. It seems to cause an error, like everything else you ever type."

Understand "type [text]" as typing it on.

Rule for supplying a missing second noun when typing on:
if the PDA is visible:
now the second noun is the PDA;
else:
say "What? You're talking complete nonsense."
</code>
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0000718)
EmacsUser (manager)
2010-10-23 08:55
edited on: 2010-10-23 09:00

The code ought to read:

say "You can't type on [a second noun].";

because there is no first noun---that position is filled by the topic. Searching for ``topic'' in the 6E72 documentation, I didn't find that fact mentioned, so this should probably be a documentation bug. Could someone move it?

(0000722)
Ron Newcomb (reporter)
2010-10-23 16:02

Is it a doc bug? I am fairly sure that if an action only has one noun, it's called "the noun" regardless the positioning. "Second" refers to the number of nouns, not to the grammar positioning.
(0000737)
graham (administrator)
2010-10-24 05:40

This is only "fixed" in the sense that the value of noun here has been corrected to "nothing", thus avoiding type unsafety, and avoiding the programming errors. The source text is indeed wrong to refer to the noun when it means the second noun.

Topics are not, in fact, an exception in this respect; exactly the same would have happened if the action had been applying to one number and one thing. The noun would be "nothing", the second noun would be the thing in question, and the "number understood" would be the number in question.

- Issue History
Date Modified Username Field Change
2010-10-23 01:47 jmcgrew New Issue
2010-10-23 08:55 EmacsUser Note Added: 0000718
2010-10-23 08:55 EmacsUser Reproducibility have not tried => N/A
2010-10-23 08:55 EmacsUser Status new => confirmed
2010-10-23 08:55 EmacsUser Product Version 6E59 => 6E72
2010-10-23 08:55 EmacsUser Summary Changing the noun or second noun in a text-and-object action produces runtime errors => WI does not mention that the thing in actions ``applying to one topic and one thing'' is the second noun, not the first
2010-10-23 08:56 EmacsUser Note Edited: 0000718 View Revisions
2010-10-23 09:00 EmacsUser Note Edited: 0000718 View Revisions
2010-10-23 16:02 Ron Newcomb Note Added: 0000722
2010-10-24 05:40 graham Note Added: 0000737
2010-10-24 05:41 graham Status confirmed => resolved
2010-10-24 05:41 graham Resolution open => fixed
2010-10-24 05:41 graham Assigned To => graham
2010-10-24 12:06 jmcgrew Reporter jmcgrew => email
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:31 jmcgrew Status resolved => closed
2010-10-29 09:02 jmcgrew Reporter email => alex


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker