Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000341Core InformKinds and type checkingpublic2010-10-22 11:392010-10-28 00:31
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.4
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000341: Kinds of kinds seem to be allowed, but excess occurrences of ``kind of'' are ignored.
Description- - - -
Metametakind is a kind of kind of kind.
- - - -

is exactly equivalent to

- - - -
Metametakind is a kind.
- - - -

Because the ``kind of'' is allowed to appear an arbitrary number of times.
Minimal Source Text To Reproduce
There is a room.
Metametakind is a kind of kind of kind.
TagsNo tags attached.
Effect(mild) Compiler accepts invalid code
Attached Files

- Relationships

-  Notes
(0000732)
graham (administrator)
2010-10-24 02:56

This now produces a polite problem message.

- Issue History
Date Modified Username Field Change
2010-10-22 11:39 EmacsUser New Issue
2010-10-23 00:18 jmcgrew Status new => confirmed
2010-10-24 02:56 graham Note Added: 0000732
2010-10-24 02:56 graham Status confirmed => resolved
2010-10-24 02:56 graham Resolution open => fixed
2010-10-24 02:56 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:31 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker