Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000339Core InformKinds and type checkingpublic2010-10-22 11:262010-10-28 00:31
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.4
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000339: Setting a usual property of a kind breaks the parse tree
DescriptionProblem. An internal error has occurred: The initial parse tree is broken. The error was detected at line 258 of "Chapter 6/Verify Parse Tree.w". This should never happen, and I am now halting in abject failure.
What has happened here is that one of the checks Inform carries out internally, to see if it is working properly, has failed. There must be a bug in this copy of Inform. It may be worth checking whether you have the current, up-to-date version. If so, please report this problem via www.inform7.com/bugs.

 As for fixing your source text to avoid this bug, the last thing you changed is probably the cause, if there is a simple cause. Your source text might in fact be wrong, and the problem might be occurring because Inform has failed to find a good way to say so. But even if your source text looks correct, there are probably rephrasings which would achieve the same effect.
Minimal Source Text To Reproduce
There is a room.
The printed name of a kind is usually "xyzzy."
TagsNo tags attached.
Effect(critical) Compiler reports internal error
Attached Files

- Relationships

-  Notes
(0000727)
graham (administrator)
2010-10-24 00:27

Interesting one, this; there was a perfectly good problem message to catch it, but which was never seen, since an internal sanity-check on the parse tree had taken fright before it had a chance. I have made the sanity check more tolerant of eccentricity.

- Issue History
Date Modified Username Field Change
2010-10-22 11:26 EmacsUser New Issue
2010-10-22 11:53 EmacsUser Severity mild => critical
2010-10-23 00:11 jmcgrew Status new => confirmed
2010-10-24 00:27 graham Note Added: 0000727
2010-10-24 00:27 graham Status confirmed => resolved
2010-10-24 00:27 graham Resolution open => fixed
2010-10-24 00:27 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:31 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker