Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000334Documentation, Examples, and Web SiteWriting with Informpublic2010-10-16 21:192010-10-29 09:23
Assigned Tograham 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version6F95 
Summary0000334: Perhaps a word about EPS, BoundingBox, and PageSize?
DescriptionI finally cared enough to dig in to why only a little bit of my map was showing up in OS X Preview or in Ghostscript.

Turns out that although the Bounding Box is correct, the display application is clipping to the default page size. For Ghostscript you can use the -dDEVICEWIDTHPOINTS and -dDEVICEHEIGHTPOINTS options (for my map, that's a forest-shredding 7200 and 2000 points, respectively). I suspect in Preview you can define a custom paper size and set that to the system default and then double-clicking the map will work fine (woe unto you if you actually try to print something, though, before changing it back). I'm not near an OS X machine right now to test, though.

Illustrator and Evince don't seem to care and are happy to show you the whole map regardless of your paper size. Evince is pretty standard on Linux, there appears to be a Windows build, and there's a Darwinports port of it, so it would be a reasonable free option on all platforms.

So, to summarize: I think it's worth mentioning that and Ghostscript will by default clip the map at the default paper size, and that this can present a problem for large maps. However, the map is correctly generated, and the problem can be worked around by using Evince or by defining a suitably large page size.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
graham (administrator)
2010-10-17 03:34

This really is not a bug report, but I have added a line to the documentation.

- Issue History
Date Modified Username Field Change
2010-10-16 21:19 adam New Issue
2010-10-16 23:54 jmcgrew Priority low => normal
2010-10-16 23:54 jmcgrew Severity mild => cosmetic
2010-10-16 23:54 jmcgrew Status new => acknowledged
2010-10-17 03:34 graham Note Added: 0000702
2010-10-17 03:34 graham Status acknowledged => resolved
2010-10-17 03:34 graham Resolution open => fixed
2010-10-17 03:34 graham Assigned To => graham
2010-10-29 09:23 jmcgrew Fixed in Version => 6F95
2010-10-29 09:23 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker