Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000333Core InformAssertions and creationspublic2010-10-15 21:442010-10-28 00:31
Reporterjmcgrew 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000333: "Foo is never 5" prevents the variable's value from being initialized at all
DescriptionI7 allows a variable to be initialized with confidence-level modifiers, e.g. "usually" to let the initialization be overridden later. But if "never" is used, it prevents later initializations from taking effect.
Minimal Source Text To Reproduce
Home is a room.

Foo is a number that varies. Foo is never 5.

Foo is 16.

When play begins, say foo.
Additional InformationThe code above prints 0 instead of 16.

Perhaps "always" and "never" should just be forbidden on variables, since the values aren't checked at runtime: "foo is always 5" doesn't stop it from being changed to something other than 5.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0000699)
graham (administrator)
2010-10-16 12:45

I have indeed prohibited the use of "seldom", "never" and "always" in such sentences.

- Issue History
Date Modified Username Field Change
2010-10-15 21:44 jmcgrew New Issue
2010-10-15 21:45 jmcgrew Status new => acknowledged
2010-10-16 11:27 graham Status acknowledged => confirmed
2010-10-16 12:45 graham Note Added: 0000699
2010-10-16 12:45 graham Status confirmed => resolved
2010-10-16 12:45 graham Resolution open => fixed
2010-10-16 12:45 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:31 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker