Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000332Core InformAssertions and creationspublic2010-10-15 15:062010-10-28 00:31
Assigned Tograham 
Platformx86OSMac OS XOS Version10.6
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000332: Standard Rules' definition of command prompt unnecessarily restrictive
DescriptionThe Standard Rules currently define the command prompt without using the "usually" qualifier:

      The command prompt is [usually] ">".

This forces authors that want to change it to do so in a rule rather than declaratively. It would friendlier to add the "usually" in the definition so that authors can simply declare an alternative command prompt, e.g.:

      The command prompt is "What do you want to do? >".

The same would likely be true of any other I7-level global variable defined in the Standard Rules (can't think of any others off the top of my head, though).
Minimal Source Text To Reproduce
Test is a room.

The command prompt is "What do you want to do? >".
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
jmcgrew (administrator)
2010-10-15 21:36

Adding "usually" is more of a feature request (and thus belongs on the suggestion forum), but the error message produced by this code refers to the variable as a "property" and could stand to be more helpful in general.
graham (administrator)
2010-10-16 13:06

I have improved the problem message. I was tempted by the suggestion about making it only "usually" in the Standard Rules, but in the end didn't go for it, because it might lead the user to believe that the same would be true for "left hand status line" and ditto for right; whereas that is rather trickier because those are variables aliased to I6 template variables, and (I suspect) used as such by various extensions to produce fancy status lines. Maybe this is worth coming back to, but anyway, I fixed the bug.

- Issue History
Date Modified Username Field Change
2010-10-15 15:06 ektemple New Issue
2010-10-15 21:36 jmcgrew Note Added: 0000698
2010-10-15 21:36 jmcgrew Status new => confirmed
2010-10-15 21:38 jmcgrew Category Model world => Assertions and creations
2010-10-16 13:06 graham Note Added: 0000700
2010-10-16 13:06 graham Status confirmed => resolved
2010-10-16 13:06 graham Resolution open => fixed
2010-10-16 13:06 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:31 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker