Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000330Mac OS X Inform application[IDEs] User Interfacepublic2010-10-11 14:482010-10-29 09:19
Reporterzarf 
Assigned Toahunter 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000330: Obscure problem message for overflowing Z-machine RAM
DescriptionIf you push the RAM using beyond the 64k limit, I7 displays the "Translating the Source - Failed" screen. ("...Something must have gone wrong all the same...") The diagnostic error message is only visible in the Progress tab, which naive users won't look at.

(The documentation refers to this error in 2.14, but doesn't say where to look for it.)

This is worth an explicit problem message, saying "It's time to switch to Glulx, pal."
Minimal Source Text To Reproduce
"Test Case" by Andrew Plotkin

The Kitchen is a room.

Table of Selected Elements
Element	Symbol	Monkey
"Hydrogen"	"H"	"Monkey"
with 10000 blank rows.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000692)
jmcgrew (administrator)
2010-10-11 15:25

I can't reproduce this on Windows. When I compile this sample code for Z5 or Z8, I get a "Translating the Source - Out of Readable Memory" message that recommends switching to Glulx.
(0000693)
EmacsUser (manager)
2010-10-12 08:40

I can confirm for the Mac IDE only. Like Jesse I get a more helpful message under the Windows and Linux IDEs. Could someone move this to ``Mac OS X Inform Application?''
(0000704)
ahunter (developer)
2010-10-17 07:38

Hmm, I think at some point in the last 7 years this error message has changed from a fatal error to a plain old error. The actual text of the error message has changed too (there's a new full stop, at least). I guess the other IDEs were written after this point.

I've changed the processing code to look for standard errors and the revised text in build 02755

- Issue History
Date Modified Username Field Change
2010-10-11 14:48 zarf New Issue
2010-10-11 15:25 jmcgrew Effect (cosmetic) Error message is badly worded => (mild) Inform 6 reports errors for invalid code
2010-10-11 15:25 jmcgrew Note Added: 0000692
2010-10-11 15:25 jmcgrew Severity mild => cosmetic
2010-10-11 15:25 jmcgrew Status new => acknowledged
2010-10-12 08:40 EmacsUser Note Added: 0000693
2010-10-12 08:40 EmacsUser Status acknowledged => confirmed
2010-10-12 09:33 graham Assigned To => ahunter
2010-10-12 09:34 graham Status confirmed => assigned
2010-10-12 23:25 jmcgrew Project Core Inform => Mac OS X Inform application
2010-10-12 23:26 jmcgrew Category Releasing, bibliographic data, cBlorb => User Interface
2010-10-17 07:38 ahunter Note Added: 0000704
2010-10-17 07:38 ahunter Status assigned => resolved
2010-10-17 07:38 ahunter Resolution open => fixed
2010-10-29 09:19 jmcgrew Fixed in Version => 6F95
2010-10-29 09:19 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker