Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000328Core InformEquations, units, arithmeticpublic2010-10-09 19:232010-10-28 00:31
Reportergrimjim 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000328: Pluralization of 0 uses singular instead of plural.
DescriptionThe game reports "This past year, 0 person starved." instead of "This past year, 0 people starved."

I presume this behavior is due to the Plurality extension, but I have not investigated to verify that hypothesis.
Minimal Source Text To Reproduce
"Bug Report 2010Oct09B" by Jim Lai

A kingdom is a kind of room.

Population is a kind of value.  1 person (singular) specifies a population.  3 people (plural) specifies 
a population.  A kingdom has population.

Starvation has a population.

Toronto is a kingdom. "O Hammurabi, I beg to report you:[line break]This past year, [population 
of starvation] starved."

When play begins:
	now the population of starvation is 0 people.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0000680)
graham (administrator)
2010-10-10 04:40

This is nothing to do with Plurality, in fact, but is because a value of 0 is printed using the "natural" unit; for instance, a length of zero will be printed as "0m" rather than "0nm" even though both are true. This rule was being applied even when the natural unit was a singular usage only, as in this case; removing that possibility fixed the bug.

I look forward to "Hammurabi Takes Toronto", an epic which will put Gilgamesh to shame.

- Issue History
Date Modified Username Field Change
2010-10-09 19:23 grimjim New Issue
2010-10-09 19:29 jmcgrew Status new => acknowledged
2010-10-09 19:29 jmcgrew Category Extensions => Equations, units, arithmetic
2010-10-10 04:37 graham Assigned To => graham
2010-10-10 04:37 graham Status acknowledged => confirmed
2010-10-10 04:40 graham Note Added: 0000680
2010-10-10 04:40 graham Status confirmed => resolved
2010-10-10 04:40 graham Resolution open => fixed
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:31 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker