Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000325Core InformUnderstandingpublic2010-10-09 12:252010-10-29 09:02
Assigned Tograham 
PlatformOSMac OS XOS Version
Product Version6E59 
Target VersionFixed in Version6F95 
Summary0000325: Can't use adjectives to limit understood values
DescriptionThe code below produces a confusing error:

Problem. You wrote '"undo"' : but this is not a condition I am able to test, or at any rate not during play.
Minimal Source Text To Reproduce
A spell is a kind of value. Xyzzy is a spell.

Casting is an action applying to one spell. Understand "cast [possible spell]" as casting.

Definition: a spell is possible: yes.

Place is a room.
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships

-  Notes
graham (administrator)
2010-10-10 03:41

It appears this was never implemented; once the spurious problem message was removed, Inform was translating "[possible spell]" to an I6 noun-filter token, which works only on objects. I have now implemented such tokens using GPRs, and the result appears to work nicely.

Really a different bug fix altogether, but in testing this I was alarmed to find that

Definition: a spell is possible: if it is xyzzy, yes; no.

didn't work, because "it" had the wrong kind of value. I've fixed this as well.

- Issue History
Date Modified Username Field Change
2010-10-09 12:25 jmcgrew New Issue
2010-10-09 12:25 jmcgrew Status new => confirmed
2010-10-10 03:41 graham Note Added: 0000677
2010-10-10 03:41 graham Status confirmed => resolved
2010-10-10 03:41 graham Resolution open => fixed
2010-10-10 03:41 graham Assigned To => graham
2010-10-24 12:06 jmcgrew Reporter jmcgrew => email
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:31 jmcgrew Status resolved => closed
2010-10-29 09:02 jmcgrew Reporter email => alex

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker