Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000321Core InformActionspublic2010-10-02 19:562010-10-28 00:31
ReporterRon Newcomb 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
PlatformPPCOSMac OS XOS Version10.4
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000321: Two-noun actions with "that" as preposition can't be in a kind-of-action
DescriptionProblem message "I can't find a verb I know how to deal with" appears for

     Answering someone that is unmaidenly behavior.

as well as any other action which uses the word "that" as the separating preposition. The type of the second noun does not matter, as illustrated by the two-object example below.

(Perhaps Inform thinks I'm trying to create a relative clause, like "that is in the location"? I don't know.)

Minimal Source Text To Reproduce
"That what?"

Asking someone for is unmaidely behavior.
Asking someone about is unmaidely behavior.
Answering someone that is unmaidenly behavior.
Throwing something at is unmaidenly behavior.
Putting something on is unmaidenly behavior.

Telling it that is an action applying to two things.  [new action, two Things this time]
Telling someone that is unmaidenly behavior.   [same problem]

spot is room.
Additional InformationThe problem messages happen really quick in the compilation process:

++ 15% (Drawing inferences)
  >--> You wrote 'Answering someone that is unmaidenly behavior' (source text, line 5):
    but I can't find a verb here that I know how to deal with, so I am ignoring
    this sentence altogether.
  >--> You wrote 'Telling someone that is unmaidenly behavior' (source text, line 10):
    again, I can't find a verb here that I know how to deal with.
Inform 7 has finished.
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships

-  Notes
(0000671)
graham (administrator)
2010-10-03 17:21

Fixed. (The problem is that it considers "that is" to be a relative clause modifying the action, so it reads the sentence as a noun phrase with no verb. It now tries to read "that is" as a relative clause first, and if that doesn't work, then tries "is". This makes both sentences work as intended.)

- Issue History
Date Modified Username Field Change
2010-10-02 19:56 Ron Newcomb New Issue
2010-10-02 20:25 jmcgrew Status new => acknowledged
2010-10-03 11:22 EmacsUser Status acknowledged => confirmed
2010-10-03 17:21 graham Note Added: 0000671
2010-10-03 17:21 graham Status confirmed => resolved
2010-10-03 17:21 graham Resolution open => fixed
2010-10-03 17:21 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:31 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker