Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000294Core InformScenespublic2010-09-16 21:122010-10-28 00:30
Reportermikegentry 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000294: scene cannot trigger itself
DescriptionYou can link 2 scenes by specifying that scene 2 begins when scene 1 ends. However, you cannot cause scene 1 to begin when scene 1 ends. This silently fails -- it does not cause a problem message during compile, but it also fails to have the desired effect at runtime.
Minimal Source Text To Reproduce
Home is a room.

Repetition is a recurring scene. Repetition begins when play begins. Repetition ends when the time since 
Repetition began is 3 minutes. Repetition begins when Repetition ends. 

Test me with "scenes / z / z / z / z / scenes".
Additional InformationEither this should be fixed so that a scene can cause its own beginning, or if that is not feasible such a situation should be disallowed, throwing a problem message at compile time.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0000558)
EmacsUser (manager)
2010-09-17 11:39

Confirmed. The line ``Repetition begins when Repetition ends'' is translated to an empty if:

if (scene_status-->1 == 0) {
}
(0000576)
graham (administrator)
2010-09-21 17:08

This was due to an over-anxious safety measure, intended to stop infinite recursion of scenes causing each other. Fixed now.

- Issue History
Date Modified Username Field Change
2010-09-16 21:12 mikegentry New Issue
2010-09-16 23:57 jmcgrew Status new => acknowledged
2010-09-17 11:39 EmacsUser Note Added: 0000558
2010-09-17 11:39 EmacsUser Status acknowledged => confirmed
2010-09-21 17:08 graham Note Added: 0000576
2010-09-21 17:08 graham Status confirmed => resolved
2010-09-21 17:08 graham Resolution open => fixed
2010-09-21 17:08 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker