Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000286Core InformActionspublic2010-09-10 20:232010-10-28 00:30
ReporterRon Newcomb 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
PlatformPPCOSMac OS XOS Version10.4
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000286: "Praying is an action out of world applying to one topic with past participle prayed."
DescriptionThe line of code in the subject won't compile, and I cannot figure out any way whatsoever of getting all three pieces of information -- out of world, one topic, past participle -- into the line. This line cannot be split into multiple parts, either. Attempts to do so create a new kind-of-action if not simply throw a Problem message about the action already existing.
Minimal Source Text To Reproduce
Church is a room. Praying is an action out of world applying to one topic with past participle prayed.

Additional InformationProblem. You wrote 'Praying is an action out of world applying to one topic with past participle prayed' : but an action can only apply to things or to kinds of value, for instance: 'photographing is an action applying to one visible thing'.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
(0000548)
Ron Newcomb (reporter)
2010-09-10 20:31

Erg, found one that works:

   Praying is an action out of world with past participle prayed applying to one topic.

But the order appears to be very specific. If this isn't a bug, then may I ask this particular example be added to the documentation somewhere? Searching for "with past participle" would've found it straightaway.
(0000633)
graham (administrator)
2010-09-29 13:52

I saw no reason why this shouldn't have worked, so Inform can now read the clauses of an action definition in any order, and the source text therefore does what it intended.

(Of course the past participle clause is redundant here, since Inform can deduce "prayed" from "praying"; in fact, past participle clauses are hardly ever needed.)

- Issue History
Date Modified Username Field Change
2010-09-10 20:23 Ron Newcomb New Issue
2010-09-10 20:31 Ron Newcomb Note Added: 0000548
2010-09-10 23:22 jmcgrew Effect (serious) Compiler rejects valid code => (cosmetic) Error message is badly worded
2010-09-10 23:22 jmcgrew Severity serious => cosmetic
2010-09-10 23:22 jmcgrew Status new => confirmed
2010-09-10 23:22 jmcgrew Additional Information Updated View Revisions
2010-09-29 13:52 graham Note Added: 0000633
2010-09-29 13:52 graham Status confirmed => resolved
2010-09-29 13:52 graham Resolution open => fixed
2010-09-29 13:52 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker