Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000281Core InformReleasing, bibliographic data, cBlorbpublic2010-09-07 09:492010-10-28 00:30
Reporterjmac 
Assigned Tocuriousdannii 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.5
Product Version6E59 
Target VersionFixed in Version6F95 
Summary0000281: Apostrophe in the story title break auto-generated play.html
DescriptionIf a story's title contains an apostrophe, then the auto-generated play.html file contains malformed JavaScript, preventing the game from running on that page.
Minimal Source Text To Reproduce
"This story's website is broken" by Sam Handwich

Release along with a website and an interpreter.

Foo is a room.
Additional InformationIn the above case, the bad JS is pretty clear, on line 17 of play.html:

default_story: [ 'This story's website is broken.zblorb', 'interpreter/This story's website is broken.zblorb.js' ],

Fortunately, it seems to be contained to this one spot. Two backslashes added in the obvious places of the one problem line in play.html result in a happy, playable web-based IF work.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0000523)
jmac (reporter)
2010-09-07 12:19

This issue appears to be present in 6E72 as well.
(0000535)
curiousdannii (developer)
2010-09-07 19:59

As double quotes can't be used in story names this has an easy fix. It would be harder to fix people having slashes etc in the file name though that shouldn't happen as you're not allowed to have them in the story name.
(0000536)
curiousdannii (developer)
2010-09-07 20:07

Fixed at the Parchment GitHub.

- Issue History
Date Modified Username Field Change
2010-09-07 09:49 jmac New Issue
2010-09-07 10:00 jmcgrew Status new => acknowledged
2010-09-07 12:08 EmacsUser Status acknowledged => confirmed
2010-09-07 12:08 EmacsUser OS => Mac OS X
2010-09-07 12:08 EmacsUser OS Version => 10.5
2010-09-07 12:08 EmacsUser Platform => x86
2010-09-07 12:19 jmac Note Added: 0000523
2010-09-07 19:59 curiousdannii Note Added: 0000535
2010-09-07 19:59 curiousdannii Assigned To => curiousdannii
2010-09-07 19:59 curiousdannii Status confirmed => assigned
2010-09-07 20:07 curiousdannii Note Added: 0000536
2010-09-07 20:07 curiousdannii Status assigned => resolved
2010-09-07 20:07 curiousdannii Resolution open => fixed
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker