Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000267Documentation, Examples, and Web SiteExamplespublic2010-08-26 13:162010-10-29 09:23
ReporterEmacsUser 
Assigned Toemshort 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.5
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000267: The note on the test string in example 230, The Unexamined Life, is specific to the Z-machine.
DescriptionAt the end of example 230, there is the following text:

(Note that, if using TEST ME to run through the solution, we will have to answer a few yes/no questions along the way.)

However, when the example is run under Glulx, the ``if the player consents'' queries also draw commands from the test string, which is

Test me with "hint about wight / north / get bar / south / open tomb / get dagger / south / hint about wight / read inscription / hint about wight / attack wight / throw dagger at wight / south".

In other words, these questions are not directed to the author piloting the example as the note would suggest. Instead, because the test string omits the yes/no answers, the test is derailed:

- - - -
>test me
(Testing.)

>[1] hint about wight
You're missing an object that might be useful to resolving this problem.

Shall I go on? > [2] north
Please answer yes or no.> [3] get bar
Please answer yes or no.> [4] south
Please answer yes or no.> [5] open tomb
Please answer yes or no.> [6] get dagger
Please answer yes or no.> [7] south
Please answer yes or no.> [8] hint about wight
Please answer yes or no.> [9] read inscription
Please answer yes or no.> [10] hint about wight
Please answer yes or no.> [11] attack wight
Please answer yes or no.> [12] throw dagger at wight
Please answer yes or no.> [13] south
Please answer yes or no.>
- - - -

For Glulx, the code should instead read something like

Test me with "hint about wight / y / north / get bar / south / open tomb / get dagger / south / hint about wight / y / read inscription / hint about wight / y / attack wight / throw dagger at wight / south".
TagsNo tags attached.
Attached Files

- Relationships
related to 0000752closed Core Inform TEST ME scripts break on "if the player consents" on Z-machine only (with possible solution) 

-  Notes
(0000444)
dchapes (reporter)
2010-08-26 18:46

I tested this and it turns out that this is a Glulx vs Z-machine issue (or perhaps Glulxe/Git vs Frotz). When compiled as Z5 or Z8 it behaves as the comment in the example indicates; the test script is paused for player input. Only when compiled to Glulx does the game take yes-no input from the test script as this issue suggests.

The comment in the example could probably just indicate this difference, but ideally the behaviour should be the same either way (preferably always taking the response from the testing script).
(0000446)
EmacsUser (manager)
2010-08-27 08:07

Good catch. I've updated the description field.
(0000449)
emshort (administrator)
2010-08-29 04:43

I don't know whether it's possible to make the Glulx/Z-machine line up in this way (something for the suggestions forum, possibly). But I have revised the example to clarify the difference and provide an alternate test me for use with Glulx.

- Issue History
Date Modified Username Field Change
2010-08-26 13:16 EmacsUser New Issue
2010-08-26 18:46 dchapes Note Added: 0000444
2010-08-27 08:07 EmacsUser Note Added: 0000446
2010-08-27 08:07 EmacsUser Summary Test string in example 230, The Unexamined Life, is out of date. => The note on the test string in example 230, The Unexamined Life, is specific to the Z-machine.
2010-08-27 08:07 EmacsUser Description Updated View Revisions
2010-08-29 04:43 emshort Note Added: 0000449
2010-08-29 04:44 emshort Assigned To => emshort
2010-08-29 04:44 emshort Status new => resolved
2010-08-29 04:44 emshort Resolution open => fixed
2010-10-29 09:23 jmcgrew Fixed in Version => 6F95
2010-10-29 09:23 jmcgrew Status resolved => closed
2011-09-20 11:28 EmacsUser Relationship added related to 0000752


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker