Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000262Documentation, Examples, and Web SiteWriting with Informpublic2010-08-23 01:582010-10-29 09:23
ReporterJuhana 
Assigned Toemshort 
PrioritynormalSeveritymildReproducibilityN/A
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000262: The manual suggests punctuation in understand text would be allowed
DescriptionChapter 16.20 gives an example:

The following command is a device to allow the tester to type a comment in to the transcript:

    Understand "! [text]" as a mistake ("Noted.").

Using that line gives a compiler error:

Problem. You wrote 'Understand "! [text]" as a mistake ("Noted.")' : but 'understand' text cannot contain literal punctuation, or more specifically cannot contain any of these: . , ! ? : ; since they are already used in various ways by the parser, and would not correctly match here.
Additional InformationThe example could be changed to Understand "* [text]" ... which works and which is the de facto standard of commenting transcripts.
TagsNo tags attached.
Attached Files

- Relationships
has duplicate 0000263closed Incorrect documentation: Understand "! [text]" as a mistake 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2010-08-23 01:58 Juhana New Issue
2010-08-23 02:13 curiousdannii Relationship added has duplicate 0000263
2010-08-23 11:54 EmacsUser Status new => confirmed
2010-08-29 06:58 emshort Assigned To => emshort
2010-08-29 06:58 emshort Status confirmed => resolved
2010-08-29 06:58 emshort Resolution open => fixed
2010-10-29 09:23 jmcgrew Fixed in Version => 6F95
2010-10-29 09:23 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker