Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000257Mac OS X Inform application[IDEs] Installation and Platform Issuespublic2010-08-20 01:012010-10-29 09:19
ReporterAaronReed 
Assigned Toahunter 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000257: Glulx stories crash with Glk error on nested say statements involving indexed text
DescriptionWhen compiling to Glulx, the following code produces a crash on the "When play begins" rule, reading "Glk Error: Unable to re-find array argument in Glk call." This source works fine in z-code.
Minimal Source Text To Reproduce
The msg is an indexed text variable.

When play begins: now msg is "[getdir]".

To say getdir: 
	let dir be indexed text;
	now dir is "east";
	say dir.
		
Cave is a room. 
TagsNo tags attached.
Attached Files

- Relationships
has duplicate 0000249closed Core Inform Passing "[current action]" with a topic to a named phrase causes Glk error 

-  Notes
(0000401)
AaronReed (reporter)
2010-08-20 01:03

Note: possible related to Issue 0000249.
(0000408)
spamalot (reporter)
2010-08-21 02:26
edited on: 2010-08-21 03:06

Unable to reproduce on Windows (Inform 7 for Windows (4th July 2010; 6E72)).
Possibly you are supposed to enter some game command to trigger the bug?

---------------------------------------------------------------------------
Translating the Source

     This is the report produced by Inform 7 (build 6E72) on its most recent run through:

The 35-word source text has successfully been translated into a world with 1 room and 1 thing, and the index has been brought up to date.
---------------------------------------------------------------------------
Cave                                                         0/1


test
An Interactive Fiction by me
Release 1 / Serial number 100821 / Inform 7 build 6E72 (I6/v6.31 lib 6/12N) SD

Cave

>
---------------------------------------------------------------------------

(0000410)
ektemple (reporter)
2010-08-21 12:06

I can't reproduce this either under 6E72, Mac OS 10.6.
(0000412)
EmacsUser (manager)
2010-08-21 14:38

I can reproduce the issue. I'll provide more details later today; this one is going to take a little while to dig into.
(0000413)
AaronReed (reporter)
2010-08-21 14:39

On my system, the crash happens immediately upon running the story-- the status bar is drawn, and then the error window appears. I'm also running 6E72 under Mac OS 10.6, so this is very strange. You both were compiling to Glulx?
(0000414)
spamalot (reporter)
2010-08-21 14:50
edited on: 2010-08-21 14:52

Glulx is selected in the settings window. Are there other settings which might be relevant?

(0000415)
ektemple (reporter)
2010-08-21 14:52

Yes, compiling to Glulx with no issues on Mac OS 10.6.
(0000416)
EmacsUser (manager)
2010-08-21 15:38
edited on: 2010-08-21 15:48

You can expose the bug by changing to git under Preferences->Advanced->Glulx Interpreter.

Edit: Zoom also lets you choose between Git and Glulxe, so I shouldn't have listed it separately.

(0000417)
ektemple (reporter)
2010-08-21 15:41

Yes, switching to Git does trigger the error. This may be an issue with CocoaGlk—Gargoyle running Git is unaffected.
(0000419)
EmacsUser (manager)
2010-08-21 17:50
edited on: 2010-08-21 17:52

This is a bug in Git:

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x00000001
0x0000b52c in glulxe_retained_unregister ()
(gdb) bt
#0 0x0000b52c in glulxe_retained_unregister ()
#1 0x2d0080a6 in -[GlkMemoryStream closeStream] ()
#2 0x2d0038b3 in glk_stream_close ()
#3 0x2d00a204 in gidispatch_call ()
#4 0x0000bf89 in git_perform_glk ()
#5 0x00005eae in startProgram ()
#6 0x0000c0ad in gitMain ()
#7 0x0000c2e4 in gitWithStream ()
#8 0x0000cd34 in glk_main ()
#9 0x0000cf3c in main ()

Looking at the disassembly, this means that aptr on line 1129 of glkop.c has become null, which should never happen.

Edit: cited wrong line number

(0000421)
DavidK (developer)
2010-08-22 00:31

This is almost certainly the retained array bug fixed in Git 1.2.6: Andrew Hunter needs to recompile the version of Git in the OS X front end.
(0000703)
ahunter (developer)
2010-10-17 07:29

Should be fixed after version 02755 of the IDE.

- Issue History
Date Modified Username Field Change
2010-08-20 01:01 AaronReed New Issue
2010-08-20 01:03 AaronReed Note Added: 0000401
2010-08-21 02:26 spamalot Note Added: 0000408
2010-08-21 02:30 spamalot Note Edited: 0000408 View Revisions
2010-08-21 02:45 spamalot Note Edited: 0000408 View Revisions
2010-08-21 02:52 spamalot Note Edited: 0000408 View Revisions
2010-08-21 02:56 spamalot Note Edited: 0000408 View Revisions
2010-08-21 03:06 spamalot Note Edited: 0000408 View Revisions
2010-08-21 12:06 ektemple Note Added: 0000410
2010-08-21 14:38 EmacsUser Note Added: 0000412
2010-08-21 14:38 EmacsUser Status new => confirmed
2010-08-21 14:39 AaronReed Note Added: 0000413
2010-08-21 14:50 spamalot Note Added: 0000414
2010-08-21 14:52 spamalot Note Edited: 0000414 View Revisions
2010-08-21 14:52 ektemple Note Added: 0000415
2010-08-21 15:38 EmacsUser Note Added: 0000416
2010-08-21 15:41 ektemple Note Added: 0000417
2010-08-21 15:48 EmacsUser Note Edited: 0000416 View Revisions
2010-08-21 17:44 EmacsUser Relationship added has duplicate 0000249
2010-08-21 17:50 EmacsUser Note Added: 0000419
2010-08-21 17:52 EmacsUser Note Edited: 0000419 View Revisions
2010-08-22 00:31 DavidK Note Added: 0000421
2010-09-29 14:16 graham Assigned To => ahunter
2010-09-29 14:16 graham Status confirmed => assigned
2010-09-29 15:30 jmcgrew Project Core Inform => Mac OS X Inform application
2010-09-29 15:31 jmcgrew Category Glulx issues (files, figures, sounds) => Installation and Platform Issues
2010-10-17 07:29 ahunter Note Added: 0000703
2010-10-17 07:30 ahunter Status assigned => resolved
2010-10-17 07:30 ahunter Resolution open => fixed
2010-10-29 09:19 jmcgrew Fixed in Version => 6F95
2010-10-29 09:19 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker