Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000248Core InformRules and rulebookspublic2010-08-14 02:432010-10-28 00:30
Assigned Tograham 
Platformx86OSMac OS XOS Version10.6
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000248: Using "an object (called O)" in the heading of an object based rulebook's rule causes a compilation error
DescriptionThe bug can also be reproduced with rulebooks based on things or containers, but I don't really see what is the point of writing a rule for an object when this rule is in a rulebook based on a child-kind of the object kind.
Minimal Source Text To Reproduce
"An object based rulebook limitation" by Phonatacid

There is a room.

The OBJ_RULEBOOK is an object based rulebook.
The THING_RULEBOOK is a thing based rulebook.

A THING_RULEBOOK for a thing (called T):
	say "[T]";
An OBJ_RULEBOOK for an object (called O):
	say "[O]";
Additional InformationWorkaround (okay this is a little silly):

An OBJ_RULEBOOK for an object:
let O be the name;
say "[O]";
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships

-  Notes
Phonatacid (reporter)
2010-08-14 03:12

Also, I'd like to point out that:

"if X is a thing:"
is compiled

"if X is an object"
is rejected by the compiler
Phonatacid (reporter)
2010-08-14 04:22

And i've just figured out that my silly workaround doesn't even work. I guess it's because the 'noun' variable is only to be used with actions or activities.
EmacsUser (manager)
2010-08-17 15:48

Confirmed, with this message:

Problem. You wrote 'An OBJ_RULEBOOK for an object (called O)' , but the description of the thing(s) to which the rule applies ('an object (called O)') did not make sense. This is an object based rulebook, so that should have described an object.
graham (administrator)
2010-09-04 13:19

The result of a curious leftover in the code from the Early Times. Deleting that, this is fixed.

- Issue History
Date Modified Username Field Change
2010-08-14 02:43 Phonatacid New Issue
2010-08-14 03:12 Phonatacid Note Added: 0000392
2010-08-14 04:22 Phonatacid Note Added: 0000393
2010-08-16 12:22 jmcgrew Status new => acknowledged
2010-08-17 15:48 EmacsUser Note Added: 0000394
2010-08-17 15:48 EmacsUser Status acknowledged => confirmed
2010-09-04 13:19 graham Note Added: 0000514
2010-09-04 13:19 graham Status confirmed => resolved
2010-09-04 13:19 graham Resolution open => fixed
2010-09-04 13:19 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker