Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000238Documentation, Examples, and Web SiteWriting with Informpublic2010-08-06 18:232010-10-29 09:23
Assigned Toemshort 
Platformx86OSMac OS XOS Version10.5
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000238: Restrictions on initials in extension author names are not clear from WI 25.3
DescriptionInform currently disallows initials in extension author names because they introduce a full stop. This limitation is not documented, though WI 25.3 does list other restrictions.
Minimal Source Text To Reproduce
New Extension by "John X. Doe" begins here.
New Extension ends here.
Additional InformationIt'd be nice to see the limitation lifted and the documentation unchanged, especially because it would make the rules governing story author names and extension author names more consistent, but I realize that there's probably a technical reason that Inform behaves as it does.
TagsNo tags attached.
Attached Files

- Relationships
related to 0000063closedgraham Core Inform Installing a poorly named extension causes all projects to fail compilation with a cryptic error 

-  Notes
emshort (administrator)
2010-08-29 07:31

I think the issue is that the extension would have to be stored in a directory whose name was John X. Doe, which is potentially problematic. I have amended the documentation.

- Issue History
Date Modified Username Field Change
2010-08-06 18:23 EmacsUser New Issue
2010-08-06 18:23 EmacsUser Relationship added related to 0000063
2010-08-08 20:17 jmcgrew Status new => acknowledged
2010-08-29 07:31 emshort Note Added: 0000455
2010-08-29 07:32 emshort Assigned To => emshort
2010-08-29 07:32 emshort Status acknowledged => resolved
2010-08-29 07:32 emshort Resolution open => fixed
2010-10-29 09:23 jmcgrew Fixed in Version => 6F95
2010-10-29 09:23 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker