Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000235Documentation, Examples, and Web SiteWriting with Informpublic2010-08-05 19:032010-10-29 09:23
ReporterTristano 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000235: Layout problem in "Writing with Inform": no wrap-up of text
DescriptionIn Chapter 9.2 (Time / Awarding points) ...

The beta notice ("In previous builds, Inform had a special phrase for adding to the score..."): the box that follows (grey with dotted red border) does not wrap up the text so, in order to view the full box, I have to expand the documentation window.

That's all ... just a style-sheet problem.

Tristano (Italy)
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000381)
Tristano (reporter)
2010-08-05 19:13

PS: I provided Chapter 9.2 as an example, but the no wrap-up problem shows up with all Beta notes in boxes in the book!
(0000383)
EmacsUser (manager)
2010-08-06 17:25

Actually, this is a problem with the Windows IDE. The text is wrapping, but its enclosing box extends slightly off the right side of the screen, and so words are sometimes cut off.

Jesse, could you move this to the IDE project?
(0000652)
DavidK (developer)
2010-10-02 09:42
edited on: 2010-10-02 09:43

The underlying problem here is that the WebBrowser control used to show HTML (which is effectively Internet Explorer) is in IE5 quirks mode. This is because the HTML for the documentation doesn't have a "!doctype" declaration at the start.

Really all the HTML in Inform 7 should have a "!doctype" (as should all HTML these days): IE isn't alone into going into a "quirks" mode if one isn't found.

The solution is to go through the indoc and i7 sources for any places where HTML files are started: searching for "<html><head>" is a good start. Before the "<html>" bit a "!doctype" declaration should be written out (HTML4 should be good enough), so that the HTML looks like

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"> [^]
<html><head>

This should be done for all platforms, not just Windows. As it involves changing indoc and the i7 compiler, I'm re-assigning to Graham.

(0000653)
DavidK (developer)
2010-10-02 09:44

Note that Mantis has slightly messed up the declaration of the doctype example, but hopefully it should be clear what needs to be done.
(0000655)
graham (administrator)
2010-10-02 13:39

I have applied the 4.01 transitional doctype to all the HTML pages seen within Inform - documentation, index, problems, run-time problems, and so on.

- Issue History
Date Modified Username Field Change
2010-08-05 19:03 Tristano New Issue
2010-08-05 19:13 Tristano Note Added: 0000381
2010-08-06 15:56 jmcgrew Priority low => normal
2010-08-06 15:56 jmcgrew Status new => acknowledged
2010-08-06 15:56 jmcgrew Platform Windows XP Home Ed. SP3 Italian => x86
2010-08-06 17:25 EmacsUser Note Added: 0000383
2010-08-06 17:25 EmacsUser Status acknowledged => confirmed
2010-08-29 06:55 emshort Assigned To => DavidK
2010-08-30 02:38 jmcgrew Project Documentation, Examples, and Web Site => Windows Inform application
2010-08-30 02:38 jmcgrew Category Writing with Inform => User Interface
2010-08-31 06:31 graham Status confirmed => assigned
2010-10-02 09:42 DavidK Note Added: 0000652
2010-10-02 09:43 DavidK Note Edited: 0000652 View Revisions
2010-10-02 09:44 DavidK Note Added: 0000653
2010-10-02 09:44 DavidK Project Windows Inform application => Core Inform
2010-10-02 09:45 DavidK Project Core Inform => Documentation, Examples, and Web Site
2010-10-02 09:46 DavidK Category User Interface => Writing with Inform
2010-10-02 09:46 DavidK Assigned To DavidK => graham
2010-10-02 13:39 graham Note Added: 0000655
2010-10-02 13:39 graham Status assigned => resolved
2010-10-02 13:39 graham Resolution open => fixed
2010-10-29 09:23 jmcgrew Fixed in Version => 6F95
2010-10-29 09:23 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker