Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000224Core InformListspublic2010-07-31 14:522010-10-28 00:30
Reporterektemple 
Assigned Tograham 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000224: Figures having "with" in their names are interpreted as objects in lists of figures
DescriptionA figure name containing the word "with" is misinterpreted as an object when used in a list, e.g.:

"The sentence 'Ducks-in-a-row is {Figure of Duck with Hat, Figure of Duck with Hat, Figure of Duck with Hat, Figure of Duck with Hat}' tells me that 'Ducks-in-a-row', which is a list of figure names that varies, should start out with the value '{ figure of duck', but this is an object and not a list of figure names."
Minimal Source Text To Reproduce
Figure of Duck with Hat is the file "Duck with Hat.png".

Ducks-in-a-row is a list of figure names that varies. Ducks-in-a-row is {Figure of Duck with Hat, Figure 
of Duck with Hat}.

Test is a room.
TagsNo tags attached.
Effect(critical) Inform 6 compiler reports errors for valid code
Attached Files

- Relationships

-  Notes
(0000366)
EmacsUser (manager)
2010-08-02 08:02

Confirmed, though perhaps this bug needs to be reclassified; it could be that the usual restrictions on the word ``with'' should also apply to figure names, so that this error message is missing:

Problem. You wrote 'Figure of Duck with Hat is the file "Duck with Hat.png".' : but this looked to me as if it might be trying to create something which has certain properties, and that made no sense on investigation. This sometimes happens if a sentence uses 'with' a little too liberally, or to specify a never-declared property. For instance, 'An antique is a kind of thing with an age.' would not be the right way to declare the property 'age' (because it does not tell Inform what kind of value this would be). Instead, try 'An antique is a kind of thing. An antique has a number called age.' It would then be all right to say 'The Louis Quinze chair is an antique with age 241.'
(0000465)
graham (administrator)
2010-08-31 05:48

Yes, I took the view that such names are better avoided, and have put in a suitable problem message.

- Issue History
Date Modified Username Field Change
2010-07-31 14:52 ektemple New Issue
2010-07-31 18:23 jmcgrew Status new => acknowledged
2010-08-02 08:02 EmacsUser Note Added: 0000366
2010-08-02 08:02 EmacsUser Severity serious => critical
2010-08-02 08:02 EmacsUser Status acknowledged => confirmed
2010-08-31 05:48 graham Note Added: 0000465
2010-08-31 05:48 graham Status confirmed => resolved
2010-08-31 05:48 graham Resolution open => fixed
2010-08-31 05:48 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker