Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000216Core InformSource text and punctuationpublic2010-07-23 19:042010-10-28 00:30
Reporterektemple 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000216: UNDO on first turn results in misleading message
DescriptionIn 6E72, an UNDO on the first turn results in the response: "[Your interpreter does not provide "undo". Sorry!]", which is misleading since UNDO is in fact supported.

The response is changed from previous versions, where it was something like "You cannot undo what hasn't been done".
Minimal Source Text To Reproduce
Test is a room.


(Type UNDO at the first prompt)
Additional InformationThe reason for the error is that the appropriate line in Perform_Undo has been commented out (probably an oversight):

!if (turns == 1) { L__M(##Miscellany, 11); return; }
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0000501)
graham (administrator)
2010-09-03 14:29

Fixed.

- Issue History
Date Modified Username Field Change
2010-07-23 19:04 ektemple New Issue
2010-07-23 19:22 jmcgrew Status new => acknowledged
2010-07-24 15:45 EmacsUser Status acknowledged => confirmed
2010-09-03 14:29 graham Note Added: 0000501
2010-09-03 14:29 graham Status confirmed => resolved
2010-09-03 14:29 graham Resolution open => fixed
2010-09-03 14:29 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker