Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000207Core InformUnderstandingpublic2010-07-18 10:442010-10-28 00:31
ReporterEleas 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000207: Wrong parser error when an unrecognized noun begins with a pronoun
DescriptionTriggered by incorporating something into a woman and then understanding "her" to refer to things so incorporated.

Asking for "her [something mistyped]" will then result in the can't see it at the moment error, stating 'You can't see "her" ([name of the woman]) at the moment.'
Minimal Source Text To Reproduce
A wig is a kind of thing. A wig is part of every person. 
Understand "her" as a thing when the item described is enclosed by a woman.

arena is room. Anna is a woman in arena.

test me with "x her wig/x her toupee"
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
(0000296)
Eleas (reporter)
2010-07-18 10:45

This is only possible with the pronoun "her"; it does not hold for either "his" or "its".
(0000308)
EmacsUser (manager)
2010-07-18 16:10

Part of what's going on here is that ``x her'' makes sense as a command by itself. Neither ``his'' or ``its'' trigger a problem because in English we say ``x him'' and ``x it.'' You get the same behavior with this (ungrammatical) code:

- - - -
A wig is a kind of thing.
A wig is part of every person.
Understand "him" as a thing when the item described is enclosed by a man.

Arena is room.
Aaron is a man in arena.
Test me with "x him wig/x him toupee"
- - - -

As for the visibility error, Inform correctly recognizes that the player cannot see ``her toupee.'' But then this bit of code from CantSee grabs the first word of the misunderstood part, decides that a pronoun was misunderstood (like if the player said ``x her'' after the character in question had left), and eventually the error is reported for Anna rather than her toupee.

- - - -
    w = NextWord();
    e = CANTSEE_PE;
    if (w == pronoun_word) {
        pronoun__word = pronoun_word; pronoun__obj = pronoun_obj;
        e = ITGONE_PE;
    }
- - - -
(0000665)
graham (administrator)
2010-10-03 15:51

CantSee() now avoids the pronouns error message if the parser is at the end of the grammar line and there are further, therefore spurious, words following the pronoun. This can still be fooled by some commands, but it makes this source text work better, so it's a net gain. In the end, it's not always easy to distinguish "her" from "her".

- Issue History
Date Modified Username Field Change
2010-07-18 10:44 Eleas New Issue
2010-07-18 10:45 Eleas Note Added: 0000296
2010-07-18 14:11 jmcgrew Severity mild => cosmetic
2010-07-18 14:11 jmcgrew Status new => acknowledged
2010-07-18 14:11 jmcgrew Category Kinds and type checking => Understanding
2010-07-18 16:10 EmacsUser Note Added: 0000308
2010-07-18 16:10 EmacsUser Status acknowledged => confirmed
2010-07-18 16:14 EmacsUser Summary Parser error "can't see it" misfiring when "her" pronoun is used => Wrong parser error when an unrecognized noun begins with a pronoun
2010-10-03 15:51 graham Note Added: 0000665
2010-10-03 15:51 graham Status confirmed => resolved
2010-10-03 15:51 graham Resolution open => fixed
2010-10-03 15:51 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:31 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker