Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000205Core InformExtensionspublic2010-07-16 21:122010-10-28 00:31
ReporterRon Newcomb 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
PlatformPPCOSMac OS XOS Version10.4
Product Version6E59 
Target VersionFixed in Version6F95 
Summary0000205: The paste icon in extension's examples don't paste the (- I6 inclusion operator correctly.
DescriptionTitle says it all, but see Eric's 1st post in http://www.intfiction.org/forum/viewtopic.php?f=7&t=1225 [^] which states:
------------------------------------
When I click the paste button for the second example, the statement:

To say miscellaneous library message (N - a number): (- L__M(##Miscellany,{N}); -).

Is posted into the code window as:

To say miscellaneous library message (N - a number): (--) L__M(##Miscellany,{N}); -) .
-----------------------------------------
I can't find a workaround, either. But sometimes, depending on how I place newlines and such, the ending -) (the true one) is deleted.
Tagswrongeffect
Effect(cosmetic) Index is created incorrectly
Attached Files

- Relationships
related to 0000377closedgraham Extension documentation prettifier drops final -) of multiline I6 inclusions in example code 

-  Notes
(0000287)
jmcgrew (administrator)
2010-07-17 16:19

Should be moved to Core Inform > Extensions if this happens on other platforms too.
(0000356)
jmcgrew (administrator)
2010-07-27 19:26

This also happens on Windows, although I had to add a paste button to the extension source since the second example in Default Messages doesn't have one.
(0000629)
graham (administrator)
2010-09-29 09:54

In an ideal world, of course, extensions wouldn't require their users to write I6, and then this would never arise, but there we are. I've fixed it.

- Issue History
Date Modified Username Field Change
2010-07-16 21:12 Ron Newcomb New Issue
2010-07-17 16:19 jmcgrew Note Added: 0000287
2010-07-17 16:19 jmcgrew Assigned To => jmcgrew
2010-07-17 16:19 jmcgrew Status new => acknowledged
2010-07-17 16:23 jmcgrew Assigned To jmcgrew =>
2010-07-27 19:24 jmcgrew Project Mac OS X Inform application => Core Inform
2010-07-27 19:26 jmcgrew Effect => (cosmetic) Index is created incorrectly
2010-07-27 19:26 jmcgrew Note Added: 0000356
2010-07-27 19:26 jmcgrew Status acknowledged => confirmed
2010-07-27 19:26 jmcgrew Category User Interface => Actions
2010-07-27 19:26 jmcgrew Tag Attached: wrongeffect
2010-09-29 08:50 graham Category Actions => Extensions
2010-09-29 09:54 graham Note Added: 0000629
2010-09-29 09:54 graham Status confirmed => resolved
2010-09-29 09:54 graham Resolution open => fixed
2010-09-29 09:54 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:31 jmcgrew Status resolved => closed
2010-11-01 17:17 EmacsUser Relationship added related to 0000377


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker