Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000201Mac OS X Inform application[IDEs] Skein and Transcriptpublic2010-07-11 09:292015-05-10 17:47
Reportermratzloff 
Assigned Totoby 
PrioritynormalSeverityseriousReproducibilitysometimes
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6E72 
Target VersionFixed in Version 
Summary0000201: Transcript sometimes has strange characters not found in source or game output
DescriptionWhen the command prompt contains the character "→" (U+2192, http://www.fileformat.info/info/unicode/char/2192/index.htm [^]) , but possibly others, the IDE will sometimes insert random bytes into the transcript. These strange characters do NOT appear in the source or game output.

These appear at the end of the paragraph in which the character is found (in this case, following the prompt). Other UTF-8 characters begin behaving badly, as well; random characters appear at the end of paragraphs with trademark and copyright symbols, for example.

When the prompt is changed back to the default, these issues disappear.

Frustratingly, this is not consistently reproducible. Changing the prompt, blessing the transcript, and changing it back does not cause the problem again. As such, it may be difficult to debug and fix.
Minimal Source Text To Reproduce
In an existing game file, try adding the following and observing the effect on the transcript:


When play begins:
	change the command prompt to "→ "
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000281)
mratzloff (reporter)
2010-07-11 09:56

An additional note. I suspect that this issue arises when serializing the transcript data to the file system. Closing Inform and reopening it seems to cause the problem to appear. Importantly, many (but not all) transcript entries that were previously blessed correctly have the strange characters in them.
(0000282)
mratzloff (reporter)
2010-07-13 19:22

Another update. Since changing the prompt back to the default, the ONLY turn in the transcript that is corrupted on the file system is the first turn, where I print out the trademark symbol (™) and the copyright symbol (©). All the other turns remain unaffected.

*** This strongly points to the problem being with UTF-8 characters, either the process of writing to or reading from the file system. ***
(0000284)
EmacsUser (manager)
2010-07-14 07:17

Confirmed. I'm in the middle of travels right now, which is why I've been slow to update.

1. Start Inform
2. Click on ``Start a new project...''
3. Select ``Inform 7 -> New Project''
4. Click on ``Next''
5. Browse to file location
6. Click on ``Create''
7. Enter this source text:

There is a room.

When play begins:
change the command prompt to "→ ".

8. Click ``Go!''
9. Enter ``z'' into the game
10. Quit Inform
11. Start Inform
12. Click on ``Reopen last project''
13. Open on the skein pane
14. Click the play icon on the ``z'' command (to place the sequence in the transcript; the transcript contains the text ``om'' after the prompt)

Note that the Skein.skein file is correct; it is simply presented incorrectly in Inform.
(0003647)
jmcgrew (administrator)
2015-05-10 17:47

Closing all resolved issues from 2014 and earlier.

- Issue History
Date Modified Username Field Change
2010-07-11 09:29 mratzloff New Issue
2010-07-11 09:56 mratzloff Note Added: 0000281
2010-07-11 13:34 jmcgrew Status new => acknowledged
2010-07-13 19:22 mratzloff Note Added: 0000282
2010-07-14 07:17 EmacsUser Note Added: 0000284
2010-07-14 07:17 EmacsUser Status acknowledged => confirmed
2010-08-31 06:09 graham Assigned To => ahunter
2010-08-31 06:09 graham Status confirmed => assigned
2014-03-24 07:04 toby Status assigned => resolved
2014-03-24 07:04 toby Resolution open => fixed
2014-03-24 07:04 toby Assigned To ahunter => toby
2015-05-10 17:47 jmcgrew Note Added: 0003647
2015-05-10 17:47 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker