Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000193Core InformActionspublic2010-07-08 14:082010-10-28 00:30
Assigned Tograham 
Platformx86OSWindowsOS VersionVista
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000193: Internal error on statically defined stored actions involving block type values
DescriptionThe example source results in an internal error:

In Part SR2 - Variables and Rulebooks, Section SR2/7 - The Standard Rulebooks in the extension Standard Rules by Graham Nelson:

Problem. An internal error has occurred: tried to allocate block KOV outside all stack frames. The current sentence is 'The specific action-processing rulebook has a truth state called within the player's sight' ; the error was detected at line 342 of "Chapter 22/Stack Frames.w". This should never happen, and I am now halting in abject failure.
Minimal Source Text To Reproduce
Home is a room.

Extrapolating is an action applying to one list of numbers.

The best idea yet is a stored action which varies. The best idea yet is the action of extrapolating {1, 
2, 3}.
Additional InformationI'm not sure if the code is valid or not. The player can't trigger an action such as this one, since it involves a kind of value that can't be understood, but it can be triggered programmatically and seems to work pretty well, except for this particular problem.
TagsNo tags attached.
Effect(critical) Compiler reports internal error
Attached Files

- Relationships

-  Notes
graham (administrator)
2010-09-01 02:12

I have my doubts about whether this should be legal, too. I've fixed the internal error and the code now compiles, but, hmm: we may explicitly withdraw this possibility later.

- Issue History
Date Modified Username Field Change
2010-07-08 14:08 fundin New Issue
2010-07-08 14:28 jmcgrew Status new => acknowledged
2010-07-08 15:14 EmacsUser Status acknowledged => confirmed
2010-09-01 02:12 graham Note Added: 0000475
2010-09-01 02:12 graham Status confirmed => resolved
2010-09-01 02:12 graham Resolution open => fixed
2010-09-01 02:12 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker