Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000191Core InformUnderstandingpublic2010-07-08 13:422010-10-28 00:31
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSLinuxOS VersionAny
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000191: Inconsistent clarification for ambiguous noun references
DescriptionFrom WI 17.28:

Clarifying the parser's choice of something
1. When it happens. When the player has typed an ambiguous noun reference, and Inform has made a decision about what was meant, and it matters what this decision is. (If the decision is between three identical gold coins, say, then it doesn't matter, and this activity does not take place.)

The example source creates three identical things, just as described. On the first drop command, they are all equivalent, so by the documentation there should be no clarification printed. Indeed there is not. On the second drop, the things differ by whether they are held or not, a factor that influences the parser's judgement because the Standard Rules say:

Understand "drop [things preferably held]" as dropping.

However, no command clarification is printed, suggesting that Inform has decided that it doesn't matter which thing is chosen. But on the third drop, a clarification is printed (with more objects, the clarification only occurs for the last one), even though the distinction being made---between things that are held and not held---is the same as on the previous turn.

Thus, either Inform is not behaving to specification or the documentation needs to be expanded to better explain ``it matters what this decision is.''
Minimal Source Text To Reproduce
There is a room.
Three things are held by the player.
Test me with "drop thing / g / g".
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0000664)
graham (administrator)
2010-10-03 15:38

What the parser should do in cases of ambiguity is so much a matter of personal taste that it's hard to call anything clearly right or wrong, but I've made a change here. The behaviour is now as the manual claims it is, i.e., clarification is not printed if the possibilities are indistinguishable. Previously it was that clarification was not printed if the object chosen was one of a set of several indistinguishable objects all in the same place, with a couple of provisos. This affected 9 of the 1543 test cases in the test suite, and the transcripts read better this way for 8 of them, so I've made the change.

- Issue History
Date Modified Username Field Change
2010-07-08 13:42 EmacsUser New Issue
2010-07-08 13:47 jmcgrew Status new => acknowledged
2010-07-08 16:02 jmcgrew Status acknowledged => confirmed
2010-10-03 15:38 graham Note Added: 0000664
2010-10-03 15:38 graham Status confirmed => resolved
2010-10-03 15:38 graham Resolution open => fixed
2010-10-03 15:38 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:31 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker