Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000186Core InformPhrases and functional programmingpublic2010-07-07 15:072010-10-28 00:30
Reporterfundin 
Assigned Tograham 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionVista
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000186: Use of indexed text not recognised when accessed only through a pointer in an indirectly called phrase
DescriptionI6 has this to say:

auto.inf(25416): Error: No such constant as "IT_BlobAccess"
auto.inf(25416): Error: No such constant as "CHR_BLOB"

If, as a workaround, the last line of the example source is uncommented, the code compiles but reports the wrong length:

"length extraction applied to "Hello world!"" = number: 0
Minimal Source Text To Reproduce
Home is a room.

To decide which number is the length of (T - an indexed text) (this is length extraction): decide on 
the number of characters in T.

When play begins: showme length extraction applied to "Hello world!"

[Foo is an indexed text which varies.]
Additional InformationIn the first case, the I6 errors are caused by the dynamic memory code not being included, so I7 must be missing the fact that we're using indexed text. With the workaround in place, one can see that the string is being passed as plain text rather than indexed text, which is why the wrong length is reported.

The summary might be a bit off -- not completely sure about the exact causes.
TagsNo tags attached.
Effect(critical) Inform 6 compiler reports errors for valid code
Attached Files

- Relationships

-  Notes
(0000562)
graham (administrator)
2010-09-20 12:15

This is now fixed. It was, as you surmise, failing to check that converting casts were going to be needed on the arguments, so that plain text was being used as indexed text without the necessary conversion taking place.

- Issue History
Date Modified Username Field Change
2010-07-07 15:07 fundin New Issue
2010-07-07 15:23 jmcgrew Status new => acknowledged
2010-07-07 15:51 jmcgrew Status acknowledged => confirmed
2010-09-20 12:15 graham Note Added: 0000562
2010-09-20 12:15 graham Status confirmed => resolved
2010-09-20 12:15 graham Resolution open => fixed
2010-09-20 12:15 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker