Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000180Core InformReleasing, bibliographic data, cBlorbpublic2010-07-06 05:402010-10-28 00:30
ReporterEryk 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000180: Tables in Source Text are not displayed properly
DescriptionAfter publishing in Source Text the second row of test table is coded as two separate rows:

<tr><td>2</td><td>"<span class="quote">Mesage with</span></td></tr>
<tr><td><span class="quote">line break</span>"</td></tr>

and is causes to display table with mixed up columns. I think it should be coded somthing like that:

<tr><td>2</td><td>"<span class="quote">Mesage with<br/>line break</span>"</td></tr>

Another good expamle of this inconsistency is Glass source:
http://inform7.com/learn/eg/glass/source_17.html [^]
Minimal Source Text To Reproduce
"test" by Eryk

Release along with a website, source text.

Test is a room.

Table of test messages
id	message
1	"test message"
2	"Mesage with
line break"
Tagswrongeffect
Effect(cosmetic) Index is created incorrectly
Attached Files

- Relationships

-  Notes
(0000251)
EmacsUser (manager)
2010-07-06 12:10

Confirmed.

Mantis is not showing the br tag after the word ``with'' in the suggested HTML. I'm going hunting for the Mantis documentation since this inconsistent treatment of tags has been a problem on other bugs too.
(0000254)
jmcgrew (administrator)
2010-07-06 16:24

http://www.mantisbt.org/bugs/view.php?id=9418 [^] seems to be causing the trouble. I took 'br' out of $g_html_valid_tags, so hopefully no one needs to insert an actual line break with it elsewhere.
(0000488)
graham (administrator)
2010-09-02 03:15

Fixed.

- Issue History
Date Modified Username Field Change
2010-07-06 05:40 Eryk New Issue
2010-07-06 08:26 jmcgrew Priority low => normal
2010-07-06 08:26 jmcgrew Status new => acknowledged
2010-07-06 08:26 jmcgrew Description Updated View Revisions
2010-07-06 08:27 jmcgrew Tag Attached: wrongeffect
2010-07-06 12:07 EmacsUser Description Updated View Revisions
2010-07-06 12:10 EmacsUser Note Added: 0000251
2010-07-06 12:10 EmacsUser Status acknowledged => confirmed
2010-07-06 16:19 jmcgrew Description Updated View Revisions
2010-07-06 16:19 jmcgrew Description Updated View Revisions
2010-07-06 16:24 jmcgrew Note Added: 0000254
2010-07-06 16:24 jmcgrew Description Updated View Revisions
2010-09-02 03:15 graham Note Added: 0000488
2010-09-02 03:15 graham Status confirmed => resolved
2010-09-02 03:15 graham Resolution open => fixed
2010-09-02 03:15 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker