Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000179Core InformRules and rulebookspublic2010-07-05 11:352010-10-28 00:30
Reportermikegentry 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000179: anonymously abide doesn't do what it says on the tin
Description"Anonymously abide by (a rule)" is supposed to act just like "Abide by (a rule)," except the rule that is deemed to have decided the outcome is the one abided by, not the one doing the abiding.

Not so. In both cases, the rule deemed to have decided the outcome is the rule doing the abiding.
Minimal Source Text To Reproduce
The Hinterlands of Greece is a room. The tree is here. It is fixed in place. The rock is here. It 
is fixed in place.

A person called Hercules is here.

Check an actor pushing something (this is the can't push what's fixed in place except for the tree rule):
	
if the noun is the tree, continue the action;
	otherwise abide by the can't push what's fixed in place rule.
	
The can't push what's fixed in place except for the tree rule is listed instead of the can't push what's 
fixed in place rule in the check pushing rulebook.

Check an actor pulling something (this is the can't pull what's fixed in place except for the tree rule):
	
if the noun is the tree, continue the action;
	otherwise anonymously abide by the can't pull what's fixed in place rule.
	
The can't pull what's fixed in place except for the tree rule is listed instead of the can't pull what's 
fixed in place rule in the check pulling rulebook.

Persuasion rule for asking Hercules to try pushing something: persuasion succeeds.
Persuasion rule for asking Hercules to try pulling something: persuasion succeeds.

Unsuccessful attempt by Hercules pushing:
	say "(Blocked by [the reason the action failed].)"

Unsuccessful attempt by Hercules pulling:
	say "(Blocked by [the reason the action failed].)"
	
Test me with "Hercules, push the tree /  Hercules, push the rock /  Hercules, pull the tree /  Hercules, 
pull the rock".
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0000243)
EmacsUser (manager)
2010-07-05 16:47

Confirmed. A reduced test case:

- - - -
There is a room called The Spot.

Check an actor jumping (this is the blameless rule):
anonymously abide by the block jumping rule.
The blameless rule is listed instead of the block jumping rule in the check jumping rulebook.

Test me with "actions / jump".
(0000502)
graham (administrator)
2010-09-03 15:47

Yes, this wasn't working in all cases; I believe it's fixed now.

- Issue History
Date Modified Username Field Change
2010-07-05 11:35 mikegentry New Issue
2010-07-05 12:43 jmcgrew Status new => acknowledged
2010-07-05 16:47 EmacsUser Note Added: 0000243
2010-07-05 16:47 EmacsUser Status acknowledged => confirmed
2010-09-03 15:47 graham Note Added: 0000502
2010-09-03 15:47 graham Status confirmed => resolved
2010-09-03 15:47 graham Resolution open => fixed
2010-09-03 15:47 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker