Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000174Core InformAssertions and creationspublic2010-07-05 08:072010-10-28 00:30
Reporterfundin 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionVista
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000174: Sounds/figures/external files can be created implicitly by assertions
DescriptionThe example source contains a typo which causes the compiler to create a spurious figure. This figure shows up in the index like so:

Include
Missing from the Materials\Figures folder
Filename: "include" - resource number 0
Minimal Source Text To Reproduce
Home is a room.

A tag is a kind of value.

Tagging relates various tags to various figure names. The verb to tag (he tags, they tag) implies the 
tagging relation.

Figure of Forest is the file "forest.jpg".

Outdoors is a tag. Outdoors tags Figure of Froest. [note the typo]
Additional InformationSounds and external files are similarly affected, with the addition that trying the same thing with external files also causes I6 errors.
TagsNo tags attached.
Effect(mild) Compiler accepts invalid code
Attached Files

- Relationships
has duplicate 0000226closedgraham Inform permits figures that violate the naming convention and that don't specify a file name 

-  Notes
(0000247)
jmcgrew (administrator)
2010-07-05 22:56

This also happens with other kinds of value:

<code>
Home is a room.

A tag is a kind of value.

A color is a kind of value. The colors are red, green, and blue.

Tagging relates various tags to various colors. The verb to tag (he tags, they tag) implies the tagging relation.

Outdoors is a tag. Outdoors tags brown. [not previously defined as a color]
</code>

Not sure if this is intended, but it is consistent with cases where a relation assertion creates an object.

However, it seems a little more serious with figures (and sounds), since those correspond to external files which must exist in order to release the game. It compiles, but attempting to release it produces an unhelpful cBlorb error:

Fatal error: unable to read data: filename 'C:\Users\Jesse\Documents\Inform\Projects\Scratch Materials\Figures\include'
(0000490)
graham (administrator)
2010-09-02 14:42

Suitable problem messages have been added for figure names, sound names and external files. (For other kinds, this sort of creation happens by design.)

- Issue History
Date Modified Username Field Change
2010-07-05 08:07 fundin New Issue
2010-07-05 22:56 jmcgrew Note Added: 0000247
2010-07-05 22:56 jmcgrew Status new => confirmed
2010-09-02 14:42 graham Note Added: 0000490
2010-09-02 14:42 graham Status confirmed => resolved
2010-09-02 14:42 graham Resolution open => fixed
2010-09-02 14:42 graham Assigned To => graham
2010-09-29 11:53 graham Relationship added has duplicate 0000226
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker