Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000173Core InformKinds and type checkingpublic2010-07-05 07:162010-10-28 00:30
Reporterfundin 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionVista
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000173: Descriptions of values with subordinate clauses lose their types
DescriptionThe compiler rejects the example source, saying:

Problem. In the line 'disregard numbers which are even', the text 'numbers which are even' seems to be a description of an object, but a description of a number was required.
Minimal Source Text To Reproduce
Home is a room.

To disregard (D - a description of numbers): do nothing.

When play begins: disregard numbers which are even.
Additional InformationThis is not a problem with descriptions in general: 'even numbers' works, but not 'numbers which are even'.
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships

-  Notes
(0000572)
graham (administrator)
2010-09-21 16:07

Fixed; and the problem message improved in the case where the wrong kind of description is used, because I found it a little vague.

- Issue History
Date Modified Username Field Change
2010-07-05 07:16 fundin New Issue
2010-07-05 12:41 jmcgrew Status new => acknowledged
2010-07-05 14:51 EmacsUser Status acknowledged => confirmed
2010-09-21 16:07 graham Note Added: 0000572
2010-09-21 16:07 graham Status confirmed => resolved
2010-09-21 16:07 graham Resolution open => fixed
2010-09-21 16:07 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker