Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000161Core InformHeadingspublic2010-07-02 15:442010-10-28 00:30
ReporterJuhana 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6E72 
Target VersionFixed in Version6F95 
Summary0000161: Sections with quote marks in the heading can't be replaced
DescriptionTrying to replace sections that include quote marks in their heading can't be replaced. The compiler incorrectly claims that there is no section with such heading in the extension.
Minimal Source Text To Reproduce
EXTENSION:

Test Extension by Random Q Hacker begins here.

Section - A "quoted" title

When play begins: say "Foo."

Test Extension ends here.


GAME:

Include Test Extension by Random Q Hacker.

Test is a room.

Section Replacement Section (in place of Section - A "quoted" title in Test Extension by Random 
Q Hacker)

When play begins: say "bar".

Additional InformationThe error message:

Problem. In the sentence 'Section Replacement Section (in place of Section - A "quoted" title in Test Extension by Random Q Hacker)' , it looks as if you intend to replace a section of source text from the extension 'Test Extension by Random Q Hacker', but that extension does not seem to have any heading called 'Section - A "quoted" title'. (The version I loaded was <no text>.)
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships

-  Notes
(0000592)
graham (administrator)
2010-09-26 08:35

It's a little questionable whether this was really "serious", and I really wonder if we should forbid quoted text in section titles anyway, but (for now at least) I've fixed this.
(0000599)
jmcgrew (administrator)
2010-09-26 15:24

My reasoning for marking this "serious" was that this is a case of a major feature becoming unusable with no workaround.

On the other hand, since quoted text in headings is uncommon, the condition in which it fails is probably pretty rare.

(On the third hand, that's going to be increasingly true of all long-standing bugs as Inform matures. On the fourth, one could argue that bugs that have gone unnoticed for several versions must be less serious anyway...)

- Issue History
Date Modified Username Field Change
2010-07-02 15:44 Juhana New Issue
2010-07-02 16:17 jmcgrew Severity mild => serious
2010-07-02 16:17 jmcgrew Status new => acknowledged
2010-07-02 16:27 EmacsUser Status acknowledged => confirmed
2010-09-26 08:35 graham Note Added: 0000592
2010-09-26 08:35 graham Status confirmed => resolved
2010-09-26 08:35 graham Resolution open => fixed
2010-09-26 08:35 graham Assigned To => graham
2010-09-26 15:24 jmcgrew Note Added: 0000599
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker