Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000157Core InformRelationspublic2010-07-02 06:152010-10-28 00:30
Assigned Tograham 
Platformx86OSWindowsOS VersionVista
Product Version6E59 
Target VersionFixed in Version6F95 
Summary0000157: Can't refer to block type values in conditions involving implicit searches
DescriptionThe example source results in the following I6 error:

auto.inf(26467): Error: No such constant as "I7BASPL"
Minimal Source Text To Reproduce
Home is a room.

Gambling relates various people to various lists of numbers. The verb to bet on (he bets on, they bet 
on) implies the gambling relation.

Every turn when someone bets on {1, 2, 3, 4, 5}: say "Just checking."
Additional InformationNot sure which category to put this in. In any case, the problem is that the usual I6 machinery to deal with block type values isn't being added to Prop_X functions when necessary.
TagsNo tags attached.
Effect(critical) Inform 6 compiler reports errors for valid code
Attached Files

- Relationships
related to 0000158closedgraham Can't refer to block type values in the past tense 

-  Notes
graham (administrator)
2010-09-21 00:53

This is now fixed.

- Issue History
Date Modified Username Field Change
2010-07-02 06:15 fundin New Issue
2010-07-02 06:42 jmcgrew Relationship added related to 0000158
2010-07-02 06:43 jmcgrew Status new => acknowledged
2010-07-02 16:14 EmacsUser Status acknowledged => confirmed
2010-09-21 00:53 graham Note Added: 0000564
2010-09-21 00:53 graham Status confirmed => resolved
2010-09-21 00:53 graham Resolution open => fixed
2010-09-21 00:53 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker