Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001399I6 LibraryGeneralpublic2014-08-24 01:472015-05-10 17:46
ReporterDavidG 
Assigned ToDavidG 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6/12 
Target Version6/12Fixed in Version6/12 
Summary0001399: keep_silent is being cleared when it's not supposed to
DescriptionIn http://www.intfiction.org/forum/viewtopic.php?f=19&t=15730&start=50#p79467 [^] is reported behavior of keep_silent being cleared after an action. Once set by the game author, it should stay set until the author then clears it. The library should not be doing this.
Minimal Source Text To Reproduce
Include "parser.h"; Include "verblib.h";

Object room "room" with description "Room" has light;
Object box  "box"  room with name 'box',  has container openable ~open;
Object box1 "box1" room with name 'box1', has container openable ~open;

[ Initialise;
	keep_silent = true;
	location = room;
];
Include "grammar.h";
Additional InformationRelease 1 / Serial number 140823 / Inform v6.33 Library 6/12-beta1 S

room
Room

You can see a box (which is closed) and a box1 (which is closed) here.

>open box

>open box1
You open the box1. ! WRONG

>
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0003118)
DavidG (developer)
2014-08-24 22:46
edited on: 2014-08-24 22:47

I've traced the keep_silent change to https://github.com/DavidGriffith/inform6lib/commit/cbb8983fca27e313023198e2b60c99afec9f498a [^] which was copied from https://github.com/DavidGriffith/inform-2006/commit/7bc4bf3804f2a931daf72edf99dd9f7cb7db9049. [^] This was committed by Roger Firth. I don't know what his logic was for making this change. Look for the line that looks like this:
keep_silent = 0; ! should be zero anyway, but just in case...

(0003119)
DavidG (developer)
2014-08-26 17:36

Fixed: https://github.com/DavidGriffith/inform6lib/commit/cbb8983fca27e313023198e2b60c99afec9f498a [^]
(0003464)
jmcgrew (administrator)
2015-05-10 17:46

Closing all resolved issues from 2014 and earlier.

- Issue History
Date Modified Username Field Change
2014-08-24 01:47 DavidG New Issue
2014-08-24 01:47 DavidG Status new => assigned
2014-08-24 01:47 DavidG Assigned To => DavidG
2014-08-24 22:46 DavidG Note Added: 0003118
2014-08-24 22:47 DavidG Note Edited: 0003118 View Revisions
2014-08-26 17:36 DavidG Note Added: 0003119
2014-08-26 17:36 DavidG Status assigned => resolved
2014-08-26 17:36 DavidG Fixed in Version => 6/12
2014-08-26 17:36 DavidG Resolution open => fixed
2015-05-10 17:46 jmcgrew Note Added: 0003464
2015-05-10 17:46 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker