Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001395I6 LibraryGeneralpublic2014-08-19 01:532015-05-10 17:46
ReporterDavidG 
Assigned ToDavidG 
PriorityhighSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6/12 
Target Version6/12Fixed in Version6/12 
Summary0001395: Several actions on the same line are broken
DescriptionFrom auraes at http://www.intfiction.org/forum/viewtopic.php?f=19&t=15730&start=50 [^]

Infocom games and all Inform games have allowed interactions like this: "EXAMINE APPLE. EAT APPLE" and "EXAMINE APPLE THEN EAT APPLE" to couple two different commands. This is broken. As the Library is now, either of these lines would result in a description of the apple, but nothing about eating it. Whether the apple is being held or not is irrelevant.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0003095)
DavidG (developer)
2014-08-19 23:20

It looks like https://github.com/DavidGriffith/inform6lib/commit/b53b8c7a4c54d0afb9f9731588f2d35a06d6108b [^] caused this problem. I guess it was important that the two variables stick after parser__parse() is done.

Here's the fix: https://github.com/DavidGriffith/inform6lib/commit/9acf3551c067c6b88436b84b03aff4edff2d16f1 [^]
(0003496)
jmcgrew (administrator)
2015-05-10 17:46

Closing all resolved issues from 2014 and earlier.

- Issue History
Date Modified Username Field Change
2014-08-19 01:53 DavidG New Issue
2014-08-19 01:53 DavidG Status new => assigned
2014-08-19 01:53 DavidG Assigned To => DavidG
2014-08-19 23:20 DavidG Note Added: 0003095
2014-08-19 23:20 DavidG Status assigned => resolved
2014-08-19 23:20 DavidG Fixed in Version => 6/12
2014-08-19 23:20 DavidG Resolution open => fixed
2015-05-10 17:46 jmcgrew Note Added: 0003496
2015-05-10 17:46 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker