Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001394I6 LibraryGeneralpublic2014-08-19 01:472015-05-10 17:46
ReporterDavidG 
Assigned ToDavidG 
PrioritynormalSeverityseriousReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6/12 
Target Version6/12Fixed in Version6/12 
Summary0001394: UpperCase() doesn't translate quite right
DescriptionFrom auraes in In http://www.intfiction.org/forum/viewtopic.php?f=19&t=15730&start=50 [^]

english.h in function UpperCase (c), It's not: 164 to 166 but: 164 to 165. ÿ (166) has no capital letter Ÿ in: TABLE HIGHER ZSCII CHARACTER SET. See DM4 p520.
TagsNo tags attached.
Attached Files

- Relationships
related to 0001396closedgraham Core Inform Slight error in VM_UpperToLowerCase() and VM_LowerToUpperCase() [Z-code only] 

-  Notes
(0003089)
zarf (developer)
2014-08-19 12:03

Same problem in LowerCase(). "167 to 169" should be "167 to 168", because 169 is not an upper-case letter.

(LowerCase() is never called in the standard library, whereas UpperCase is().)
(0003090)
zarf (developer)
2014-08-19 12:14

Also exists in the I7 library, so I filed bug http://inform7.com/mantis/view.php?id=1396 [^] . Note that this is Z-code only.
(0003092)
DavidG (developer)
2014-08-19 13:35

Fixed: https://github.com/DavidGriffith/inform6lib/commit/4fb600e5719c759ec88d278e3363de86d4e8b25c [^]

Thanks, Zarf.
(0003498)
jmcgrew (administrator)
2015-05-10 17:46

Closing all resolved issues from 2014 and earlier.

- Issue History
Date Modified Username Field Change
2014-08-19 01:47 DavidG New Issue
2014-08-19 01:47 DavidG Status new => assigned
2014-08-19 01:47 DavidG Assigned To => DavidG
2014-08-19 12:03 zarf Note Added: 0003089
2014-08-19 12:13 zarf Relationship added related to 0001396
2014-08-19 12:14 zarf Note Added: 0003090
2014-08-19 13:35 DavidG Note Added: 0003092
2014-08-19 13:35 DavidG Status assigned => resolved
2014-08-19 13:35 DavidG Fixed in Version => 6/12
2014-08-19 13:35 DavidG Resolution open => fixed
2015-05-10 17:46 jmcgrew Note Added: 0003498
2015-05-10 17:46 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker