Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001376I6 LibraryGeneralpublic2014-07-29 02:072015-05-10 17:46
ReporterDavidG 
Assigned ToDavidG 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version6/11 
Target Version6/12Fixed in Version 
Summary0001376: A pause function would be desireable
DescriptionI just realized that having a "pause" function would be very helpful for portability. For my games, I like to have a "press any key to continue" thing after the prologue and before the main game starts. Infocom did stuff like this. The only way I can see for doing this is to do "@read_char 1 dummy;". That won't work with Glulx. So, I would like a pause() function that portably does this.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0003013)
DavidG (developer)
2014-07-29 14:17

It looks like KeyCharPrimitive() does exactly what I'm looking for.
(0003547)
jmcgrew (administrator)
2015-05-10 17:46

Closing all resolved issues from 2014 and earlier.

- Issue History
Date Modified Username Field Change
2014-07-29 02:07 DavidG New Issue
2014-07-29 02:07 DavidG Status new => assigned
2014-07-29 02:07 DavidG Assigned To => DavidG
2014-07-29 14:17 DavidG Note Added: 0003013
2014-07-29 14:17 DavidG Status assigned => resolved
2014-07-29 14:17 DavidG Resolution open => no change required
2015-05-10 17:46 jmcgrew Note Added: 0003547
2015-05-10 17:46 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker