Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000137Core InformListspublic2010-06-28 07:172010-10-28 00:30
Reporterfundin 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionVista
Product Version6E59 
Target VersionFixed in Version6F95 
Summary0000137: Multi-level lists of indexed text are not initialised correctly
DescriptionThis is the output from the example source. The third line should have said "foo", just like the fourth.

"grid" = list of lists of indexed texts: {{"foo", "bar"}}
"entry 1 of the grid" = list of indexed texts: {"foo", "bar"}
"entry 1 of entry 1 of the grid" = indexed text:
"entry 1 of L" = indexed text: foo
Minimal Source Text To Reproduce
Home is a room.

The grid is a list of lists of indexed texts which varies. The grid is {{"foo", "bar"}}.


When play begins:
	showme the grid;
	showme entry 1 of the grid;
	showme entry 1 of entry 1 of the grid; [***]
	let L be entry 1 of the grid;
	showme entry 1 of L.

[The highlighted line is the problematic one.]
Additional InformationI think this is an initialisation issue, because the same problem does not occur when the list is constructed at run-time.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0000165)
EmacsUser (manager)
2010-06-28 12:37

Confirmed. I'll have a chance to add more details later today.
(0000168)
EmacsUser (manager)
2010-06-28 15:54

The strings "foo" and "bar' are being stored as text, not indexed text, in the global that represents the literal. Copying the list (either implicitly or explicitly) causes the appropriate conversion, which hides the bug.

As evidence for this diagnosis, the following code succeeds in printing ``text: foo'' even though it should fail:

- - - -
Home is a room.

The grid is a list of lists of indexed texts which varies. The grid is {{"foo", "bar"}}.

To decide which text is the text that should be indexed text:
(- LIST_OF_TY_GetItem(LIST_OF_TY_GetItem((+ grid +),1),1) -).

When play begins:
showme the text that should be indexed text.
- - - -

This may be a duplicate of 0000096.
(0000597)
graham (administrator)
2010-09-26 11:31

An interesting one, this. Fixed; but no relation to 0000096.

- Issue History
Date Modified Username Field Change
2010-06-28 07:17 fundin New Issue
2010-06-28 09:41 jmcgrew Status new => acknowledged
2010-06-28 12:37 EmacsUser Note Added: 0000165
2010-06-28 12:37 EmacsUser Status acknowledged => confirmed
2010-06-28 15:43 EmacsUser Relationship added related to 0000096
2010-06-28 15:54 EmacsUser Note Added: 0000168
2010-09-26 11:31 graham Note Added: 0000597
2010-09-26 11:31 graham Status confirmed => resolved
2010-09-26 11:31 graham Resolution open => fixed
2010-09-26 11:31 graham Assigned To => graham
2010-09-26 12:19 EmacsUser Relationship deleted related to 0000096
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker