Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001225Documentation, Examples, and Web SiteExamplespublic2014-04-23 19:302014-05-07 07:38
Reportermattweiner 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001225: Ex. 348, "Copper River," contains an is-are applied to a list
DescriptionIn Copper River, the following line of code:

if the noun contains something interesting:
say "[A list of interesting things in the noun] [is-are] in [the noun]";

is presumably meant to print "is" if the list contains one singular thing and "are" otherwise. But the is-are agrees with the last item in the list.
Minimal Source Text To Reproduce
Running example 348:

throw powder at Fiona/take salmon/open cabinet/take descaling solution/put salmon and solution on shelf/search 
shelf
Additional InformationOutput of the last command:

>search shelf
A very scaly salmon and a bottle of descaling solution is on the shelf (alongside assorted dull items).
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0002638)
zarf (developer)
2014-04-23 20:11

Confirmed.

[numerical is-are] is also wrong, because the "say a list" phrase does not set say__n. (Maybe it should?)


(0002666)
graham (administrator)
2014-05-04 11:44

This is all now done with adaptive text, so the issue doesn't arise.

- Issue History
Date Modified Username Field Change
2014-04-23 19:30 mattweiner New Issue
2014-04-23 20:11 zarf Note Added: 0002638
2014-04-23 20:11 zarf Status new => confirmed
2014-05-04 11:44 graham Note Added: 0002666
2014-05-04 11:44 graham Status confirmed => resolved
2014-05-04 11:44 graham Resolution open => fixed
2014-05-04 11:44 graham Assigned To => graham
2014-05-07 07:37 jmcgrew Fixed in Version => 6L02
2014-05-07 07:38 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker