Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001222Core InformTablespublic2014-04-15 14:542014-05-07 07:33
ReporterASchultz 
Assigned Tograham 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001222: Table with a (text) gives odd error
DescriptionIf we label a column a in a table, Inform gives an acceptable error.

If we label it a (text), it gives a confusing error. While the IDE does a relatively good job of giving workarounds, and an experienced programmer can guess, the "this should never happen" text pushed me to report this.
Minimal Source Text To Reproduce
"as" by Andrew Schultz

room 1 is a room.

table of junk
a (text)
"a"
Additional InformationHopefully this won't waste much time if a similar bug has already been fixed.

Full error: "An internal error has occurred: registered a meaning which was only an article. The current sentence is 'table of junk a (text) "a"' ; the error was detected at line 571 of "Chapter 10/Excerpt Meanings.w". This should never happen, and I am now halting in abject failure."
TagsNo tags attached.
Effect(critical) Compiler reports internal error
Attached Files

- Relationships

-  Notes
(0002622)
zarf (developer)
2014-04-15 20:47

Possibly a duplicate of http://inform7.com/mantis/view.php?id=669 [^] . ("a" with no name following causes an assert at the same line.)
(0002641)
graham (administrator)
2014-05-03 12:04

Yes, this is better handled now.

- Issue History
Date Modified Username Field Change
2014-04-15 14:54 ASchultz New Issue
2014-04-15 15:00 EmacsUser Effect (cosmetic) Error message is badly worded => (critical) Compiler reports internal error
2014-04-15 15:00 EmacsUser Severity mild => critical
2014-04-15 15:00 EmacsUser Status new => confirmed
2014-04-15 15:00 EmacsUser Category Kinds and type checking => Tables
2014-04-15 20:47 zarf Note Added: 0002622
2014-05-03 12:04 graham Note Added: 0002641
2014-05-03 12:04 graham Status confirmed => resolved
2014-05-03 12:04 graham Resolution open => fixed
2014-05-03 12:04 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker