Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000119Core InformPhrases and functional programmingpublic2010-06-24 14:182010-10-28 00:30
Reporterfundin 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionVista
Product Version6E59 
Target VersionFixed in Version6F95 
Summary0000119: Descriptions of numbers don't work when applied to negative numbers
DescriptionThe example source is supposed to display the list {-2, -1}, but instead it results in a run-time problem:

*** Run-time problem P59: You can't implicitly repeat through the values of this kind [...]
Minimal Source Text To Reproduce
Home is a room.

When play begins:
	showme the filter to negative numbers of {-2, -1, 0, 1, 2}.
Additional InformationDescriptions are compiled into functions taking a single argument. A negative argument signals that some specific action is to be taken, while a positive argument means 'does this value match the description?'. Testing a negative number breaks this system.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0000150)
EmacsUser (manager)
2010-06-24 14:35

Confirmed, but only for the integers from -6 to -1, inclusive. Also, because of the action it triggers, -1 fails silently.
(0000492)
graham (administrator)
2010-09-03 03:16

Mortifying. A one-line fix takes care of it, though.

- Issue History
Date Modified Username Field Change
2010-06-24 14:18 fundin New Issue
2010-06-24 14:29 EmacsUser Status new => acknowledged
2010-06-24 14:35 EmacsUser Note Added: 0000150
2010-06-24 14:35 EmacsUser Status acknowledged => confirmed
2010-09-03 03:16 graham Note Added: 0000492
2010-09-03 03:16 graham Status confirmed => resolved
2010-09-03 03:16 graham Resolution open => fixed
2010-09-03 03:16 graham Assigned To => graham
2010-10-25 21:14 jmcgrew Fixed in Version => 6F95
2010-10-28 00:30 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker