Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001181Core InformRules and rulebookspublic2014-01-12 19:482014-05-07 07:34
Reportermattweiner 
Assigned Tograham 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001181: listing a rule before itself causes an internal error
DescriptionIf you explicitly declare "The foo rule is listed before the foo rule in the baz rulebook," you get an abject failure.

Obviously the code is invalid and should be rejected by the I7 compiler.
Minimal Source Text To Reproduce
There is room.

Instead of jumping (this is the abject failure rule): do nothing.
The abject failure rule is listed before the abject failure rule in the instead rulebook.
Additional Information"This is the report produced by Inform 7 (build 6G60) on its most recent run through:

Problem. An internal error has occurred: can't find end rule. The current sentence is 'The abject failure rule is listed before the abject failure rule in the instead rulebook' ; the error was detected at line 628 of "Chapter 23/Rules.w". This should never happen, and I am now halting in abject failure.
What has happened here is that one of the checks Inform carries out internally, to see if it is working properly, has failed. There must be a bug in this copy of Inform. It may be worth checking whether you have the current, up-to-date version. If so, please report this problem via www.inform7.com/bugs.

 As for fixing your source text to avoid this bug, the last thing you changed is probably the cause, if there is a simple cause. Your source text might in fact be wrong, and the problem might be occurring because Inform has failed to find a good way to say so. But even if your source text looks correct, there are probably rephrasings which would achieve the same effect."
TagsNo tags attached.
Effect(critical) Compiler reports internal error
Attached Files

- Relationships

-  Notes
(0002289)
graham (administrator)
2014-01-13 11:44

Fixed.

- Issue History
Date Modified Username Field Change
2014-01-12 19:48 mattweiner New Issue
2014-01-13 09:15 EmacsUser Status new => confirmed
2014-01-13 11:44 graham Note Added: 0002289
2014-01-13 11:44 graham Status confirmed => resolved
2014-01-13 11:44 graham Resolution open => fixed
2014-01-13 11:44 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker