Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001171Core InformSpacing and printingpublic2013-12-30 07:092014-05-07 07:33
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSLinuxOS VersionAny
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0001171: HimHerItself prints ``theirselves'' rather than ``themselves''
DescriptionThe source of HimHerItself in Language.i6t reads

- - - -
[ HimHerItself o; if (o has pluralname) { print "theirselves"; return; }
if (o has female) { print "herself"; return; }
if (o has neuter) { print "itself"; return; }
print "himself";
];
- - - -

But ``theirselves'' is uncommon, dialect, and considered wrong by some sources. Even the template file comments use ``themselves''.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships
related to 0000854closedgraham Some verb conjugations are hard-coded and therefore don't match plural-named actors 

-  Notes
(0002229)
zarf (developer)
2013-12-30 10:21

This seems to be used in exactly one place (and is not exposed as an I7 API):

Touch: 4: print (The) actor, " touches ", (himheritself) x1, ".^";

This is going to be wrong anyhow for a plural-named actor. The library makes no attempt to deal with that case (as of 6G60) -- the verbs are always singular.

If the verb were adjusted, I agree that "themselves" would be natural.

> Fitz and Simmons touch themselves.

(A line which may in fact have already been written in fanfic.)
(0002230)
EmacsUser (manager)
2013-12-30 10:59

Yes, this came up while testing a patch for 0000854 (https://github.com/i7/extensions/blob/206c06a5f60b9f0c9732f603db6ac1ca2770bd4d/Friends%20of%20I7/6G60%20Patches.i7x#L579 [^]).
(0002403)
graham (administrator)
2014-01-28 11:27

Everything is different here in the new build, which doesn't use I6 for inflections, but yes, this is fixed.

- Issue History
Date Modified Username Field Change
2013-12-30 07:09 EmacsUser New Issue
2013-12-30 10:21 zarf Note Added: 0002229
2013-12-30 10:59 EmacsUser Note Added: 0002230
2013-12-30 10:59 EmacsUser Relationship added related to 0000854
2014-01-28 11:27 graham Note Added: 0002403
2014-01-28 11:27 graham Status new => resolved
2014-01-28 11:27 graham Resolution open => fixed
2014-01-28 11:27 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker